Keyshot 3 problem

Hello everybody !

I’m a french student and i’m actually working in a firm wich works on Rhino 5 and Keyshot 3. I never used Rhino before but that’s not the problem (I can learn… :slight_smile: )… In fact the problem comes when I launch Keyshot. I can import my Rhino model into the software and I can make my renders. But In my model I have a hidden part : a screw between two nuts (“une tige filetée” in French). I see every parts of the model but not the screw… I tried a few possibilities but I can’t find this part. And this part is really important because it maintains 13 transparent pieces (and you can the screw through the pieces)… But this part doesn’t exist in Keyshot so I can’t put a material on it…

There’s a screenshot of my model… You cans see the 13 PMMA pieces and the 8 nuts but there’s no screw in the hole…

Do someone have a solution or an ideai to solve my problem please ?

Hi Alexandre
My guess is that you have lightweight extrusions (LE) turned on. LE is a new thing in Rhino5 that will help keep file sizes down if you have a lot of extrusions. Use the command “SelExtrusion” to locate any extrusions and “ConvertExtrusion” to convert it/them into ordinary polysurfaces. If you want to skip using the lightweight extrusions alltogether, you can run the command “UseExtrusions” and select polysurfaces as the prefered output - this will be remembered the next time you start Rhino, so you only have to run it once.
HTH, Jakob

1 Like

I of course should mention, that Keyshot doesn’t recognize the lightweight extrusions and that’s why you’re not seeing it in KS :smile:

Interesting. I don’t use Keyshot, but I’m curious: Does this come about because Rhino’s exporter to a Keyshot-compatible format doesn’t automatically (or by option) convert lightweight extrusions to polysurfaces or is it because Keyshot’s .3dm importer doesn’t recognize them?

Cool I saw this command and i didn’t know it… But It doesn’t works… I can select my 4 extrusions but I can’t see them in KS. Maybe that’s my fault… I tried “SelExtrusions”, I saved the file and imported it into KS… But no Screw… Same thing with “ConvertExtrusion”… :’(

Maybe AIW is right !? Maybe KS doesn’t recognize it !? Or maybe it’s my Computer. My CPU is just a Quad core so it’s a little bit powerless for rendering… ^^’

But I’ll try again and I’ll say you… :smile:

Thank you for your answer.

It doesn’t work at all… :confused:
I trid it again and I redrew my model but KS still don’t find the screw…

I’m not familiar with KS, but how do you go from Rhino to KS?
Is that a regular export or a dedicated way KS has provided?

Try and create a mesh from the screw and try that is that also not showing up?
Might the problem be in KS not having enough “layers” of transparency where the screw is culled when behind a certain amount of transparent object?


Ok i’ll try. But could you give me some details about creating the mesh from the screw please ? I don’t know how to do it. I’m just a beginner on this Software (i worked on Solidworks for years but I never used Rhino before)… ^^

Hi Alexandre - use the Mesh command to generate a mesh object that KeyShot should be able to use. Can you post or send to one of the objects (Export just that) that KS cannot see?



Hi again
Another thing to try is to use selbadobjects to check if the objects you’re not seeing in KS are bad. That might the case and therefore the mesher is unable to export the mesh correctly.
HTH, Jakob

Finally I fixed the problem be avoiding it. In fact I just created an other screw. Before it was just a cylinder but I made all the threads and now I can see the screw in Keyshot. I’m actually generating the rendering. I’ll show it when it will be finished.
I did’nt try the “selbadobjects”. But I saw in a tuto that I could use an other tool. I don’t know if It could fix my problem but I saw someone using “solid / cap planar holes”. I haven’t try it yet. :smile:

Hi Alexandre

What might have been the cause is that the ‘invisible’ object had it’s normals pointing inward.
If you encounter such problem again, either use the Flip command to flip the direction of the surface(s) or indeed in special cases (planar holes) Cap can make the open (poly)surface into a solid, that in turn will automatically make the normals point outwards.


Ok I’ll keep it in mind Willem. You were all helpfull for me… Now I’d like to thank you with a render… ^^
It’s not perfect but I’m glad it works. That’s one of my favorites renderings about this work. :smiley:


Thank you so much!