Keyboard shortcuts + enter doesn't work with caps lock on

I have “l + enter” for "line."However, “L + enter” doesn’t work… This has been broken for quite some time.


@dan, @marlin

Sorry, I’m confused by this. How did you assign l+enter as a keyboard shortcut in Preferences > Commands > Customize > Keyboard shortcuts ? The enter key should not register at all as a viable shortcut.

Are you saying you have only l assigned to Line?

No wonder you’re confused - very bad explanation. Sorry! I don’t know what I was thinking. Must be my age… :grin: I was talking about aliases… My aliases are all imported from Win Rhino. For instance “l” + spacebar (or enter) assigned to “Line” (alias: “l”, macro: “! _Line”). This works in Win Rhino with both “l” and “L”, but “L” + spacebar doesn´t work in Mac Rhino. I wish it would.
Sorry for the confusion…


And I presume just creating another alias with L - or perhaps turning off CAPS LOCK - is not a solution that works for you?

No, not really. “Line” is not the only problem, of course… I could create double sets of all my aliases - but there are quite a lot of them. I guess I understand from your answer that correcting it in Mac Rhino isn’t easy (making aliases behave like in Win Rhino)?
Turning caps lock off isn’t a very convenient option. When creating text in 2D drawings we usually use capital letters - and I always forget to turn caps lock off when continuing modelling.
I’d prefer that you would fix it in Mac Rhino - if possible.


Sorry, I’m still not following (probably the severe cold that I currently have) :mask:

In RhinoWIP 5E63w, in RhinoWIP > Preferences > Aliases I’ve defined an l (lowercase) as ! _Line:

…then I turned on CAPS LOCK …

Works for me. What am I doing wrong?


You’re right - enter works, of course - spacebar doesn’t (which I always use). It seems to be a similar problem as we have in ‘adjustable curve blend’ - enter works, spacebar doesn’t…