Keyboard, Macro Editor, Notes and Command Line Issues

I can’t seem to figure out why, when in macro editor, with macro editor highlighted, or in notes with notes pane highlighted, that when I type it goes straight to the command line.

I just updated Rhino, to the most recent release. I recall seeing that rhino was up to date earlier today. I downloaded and installed a plug-in, GenBolt today too. I believe I did the Rhino update afterwards.

Anyways, I cant edit text inside either macroeditor or notes inside rhino.

Is there a setting, to set some kinda priority for text or something? I cant find anything in any options under keyboard, or shortcuts or anything.

I did find a thread about why single letter keys cannot be hotkeyed, because programs like rhino with commands cant tell the difference. Which will be useful when I get my keyboard soon, with programmable multiplier keys. Now I know why single keys cant be used. I’m a use multiplier keys, and the f1-12’s and stick to them. Then I’ll have 84 commands/toolbar popups/macros, and be somewhat easy to remember them with a cheatsheet.

Anywho, is there a setting or a bug in the latest release???

Update, Calculator is working normally, with numbers from above letters and keypad.

Webbrowser working fine as well. Still no notes or macro editor.

Update: I restarted my computer. I don’t remember if I did after the update. The macro editor was the same. Then I decided to do it in windows notepad. I copied from windows notepad, and ran the command. Then I deleted it. Then typing in macro editor worked. So I decided to play. Clicked in viewport, etc…

It works sometimes when I click in the macro editor pane and type, and sometimes it doesn’t. For it to work, you need to have some text in the macro editor.

This is a bug (IMO) in that if you have the panels docked, and you click on the tab to activate the panel - leaving the cursor where it is on the tab - then start typing, the typing goes to the command line. If you move the cursor into the panel space and click once, the typing goes to the panel as desired. What it looks like is the panel’s tab screen space and border are not being taken into consideration when deciding which part of Rhino has focus.

The same happens with undocked panels if you don’t click in the actual writing area to activate them, but click on either the title bar or tab instead. In that case the typing goes nowhere, neither to the command line nor to the panel.

Does that correspond with what you’re seeing?

I have filed this as a bug.


Okay, thank for the response. I was clicking inside the white text area of the panel, but wasn’t sure if I had left my cursor in the box while typing. I only ran into it once or twice today. Once you get something copied and pasted, its alright. It did happen with a macro in there, but clicking and playin around a bit got it back. My macro editor tab is over pretty far though. At about half the entire program space on screen, so this likely has something to do with it since you mentioned rhino being a little confused about whether its a viewport or docked panel.

Thanks, now I know what to look for. When you say click on undocked panels at the tab or title bar, you mean the top of the window? Where you either make it active, or move the panel? I suppose some people might not get it!

Update 12-21-2014 5:33 central time, when command help is docked or undocked, same stuff is happening. Clicking in search area, nothing. Escape key, click in viewport, click back nothing.

This issue is now fixed. The fix should be available in the next Rhino 6 WIP release.