Keyboard layout switching

Hello, does anyone have similar problem with foreign lanueage keyboard setup on win 10? My keyboard layout is constantly switching to Czech CS qwertz. I have default set ENG and CSQ (qwerty). My windows is Czech version, 1903 bult. When I start Rhino (or other programs like Modo), but I recognize due to shotcuts mainly in Rhino) Win 10 automatically ad CS (qwertz) layout and I have to manually delete it (but first I have to ad the layout to be able to delete!). After restart, the problem is back. I beleive this is a System problem but on other forums, there is only advice to delete it but this is not the solution. Perhaps there is an adjusting registry trick.