Kangaroo error:1. Solution exception:Index was out of range

Hello,
I am working on the kinetic structure consisting of origami and moving on the z axis when the user approaches. The aim is to move upwards on the z axis by using the attraction point to certain points of a plane that I produce using the Ron Resch pattern. In my grashopper file attached below, my main goal was to define the points of the origami, to draw the valley and mountain lines from these series and to attract the points that the attraction point will affect. When I run the Kangaroo plug-in, I get the error, ‘Solution exception: Index was out of range.Solution exception:Index was out of range. Must be non-negative and less than the size of the collection.’ Since I am new to the grashopper, it has been a little complicated and I cannot develop a solution either. I also had the goal of connecting the Ron Resch pattern to an array, adding modules to the origami surface as the parameters change, but I was not successful. I will be grateful if you could help me.
deneme_yeni başlangıç_kangaroo.gh (69.6 KB)

There is a bigger problem:

The error you get is probably because some spring/line is using for both extremities the same point/particle (or 2 point that are near enough that kangaroo merge them as one).
Fixing this is much more difficult because of the complex datatree structure you are using, using a better construction would simplify everything.

I no longer have old kangaroo , would you be ok with a solution for latest kangaroo?

3 Likes

Hello,
Unfortunately, I was able to link lists in a very complicated way because I’m so new to Grasshopper. I too get lost and can’t fix it.
I will be very happy if you can help.

The latest version is suitable for me . Thank you so much.


origami.gh (29.8 KB)

Note that, this kind of origami easily have high deformation.
It starts flat and it ends flat when completely folded… but at the in-between angles it is forcefully curved.
High modules count would need too much double curvature, it deform.

To (try to) avoid deformations, turn off hinge goal (or set strength to zero) when you reached the shape you want, this let the “Spring from mesh” component relax the mesh correctly.

2 Likes

Thanks for your help. It helped a lot to understand how it works.

1 Like