Just upgraded to V6 Mac - observations

Having just installed the V6 upgrade I’m finding a few things either not functioning, functioning strangely or I have one of the new settings mixed up.

1.) First, I have a newfloatingviewport icon under “Viewport Layout” but it does absolutely nothing. When clicked, nothing happens. Command history shows the command working but Im expecting a new viewport with the option to set the view. I make heavy use of this in V5.

2.) When I begin to type a command in V5 I get a suggestion filter list. In V6 I get no list. Just the command entry line.

3.) In V5 the properties panel was visible in the sidebar along with various others. Now it seems that you can only either have the properties panel or a combination of the other panels. I use this a lot to determine the properties of the selected object.

4.) I have a number of viewport styles which automatically migrated from V5. I created a simple primitive, set the viewport to one of my legacy styles (worked fine), then set it to Arctic (also worked fine), then I toggled to raytraced and Rhino just hung. It never recovered and when I attempted to relaunch it wouldn’t relaunch. I had to restart my Mac mini ( I know about the lack of dedicated GPU) to get the app to launch again.

Maybe I’m missing something. Any direction would be helpful.

Update…

1.) FYI… I am running Mojave with 32g RAM and noticed an update (12.14.6). I just applied the update and now the newfloatingviewport works. (resolved)

2.) Also I now get the command suggestion list. (resolved)

3.) Properties panel still works as I detailed before.

4.) Changing display styles still causing problems.
I start a new session and switch to perspective. I set the default (Out Of Box) “shaded” as the style. I create a simple 3D box, change the style to OOB wireframe (works fine), change back to retraced (works fine), then I switch back to OOB wireframe and get the twirl of death. Wait 5 minutes and Rhino never responds. Have to force quit and then Rhino won’t launch again. Forced to restart the os and then things work again.

Regarding property panel…

So I have set from Preferences -> Themes->Modeling Inspector Sidebar to 4 and the little gear icon at the top right of the top most right side panel set to “show properties panel” and get a setup that works pretty good for me,

That little gear is on the top right of all the panels so you can make any of them show properties or be inspector panels as you wish.

Is that what you are wanting?

@Cp Knight
Thank you for responding. I guess my issue is with screen real estate. I had experimented with increasing the sidebar count and dedicating a “container” to the properties panel but that means I have to shrink real estate for other panels that I treat with the same level of importance.

What was confusing to me was that this particular panel was treated differently than all the other inspector options. There is already a functioning container housing all the other panels so unless there was a technical problem nesting this particular panel it didn’t make sense why this one was different. Especially when in properties panel mode there are no additional panel objects to turn on.

I do have the option to float the panel if I want to give up screen space and treat this differently but in my opinion that impacts the amount of actual modeling real estate and modeling is what I am most interested in. Nesting it along with the other inspector panels just seemed more logical.

I really do appreciate your response and I will just have to adjust my workflow accordingly. I know each individual works differently and things are bound to change. I just wanted to make sure I hadn’t configured something that caused the properties panel to react differently.

Thanks again…

1 Like

One observation of mine: I am finding it is much more difficult to see curves on V6 than V5. I cannot figure out why. The background color is the same. If anyone else has found this to be the case, have you found a solution:

I don’t think this is my imagination. The cyan curves are hard very hard to see:

Worse yet, I do a selection and curves appear that were not otherwise visible:

And moving around the curves become visible on their own. They are green and orange so they should stand out.

Can try:

Bump up all display modes where wireframes, curves, isocurves defaulted to 1 - change to 2, and all 2s (e.g. surface edges) to 3s.

Thanks,

That was a good suggestion.

Great! Bugged me as well until I got a clue…

The variance in default settings visual line quality between v5 and v6 seems to be tied to specific computer model/specification in v6, whereas in v5, no significant discrepancy was ever noticed across models.

For example: on 27” 5k iMacs the v6 default display mode settings appear fine. (similar enough to v5) Conversely, on a MacPro with 32” 4k display, line quality is horrible at default setting! Happily, line quality is restored to within parameters consistent with v5 (or v6 on 5k iMac) on this specific hardware via the alteration described above.