Jumping Transparency

Is there a way to accomplish a more gradual scale of transparency? I can only accomplish two levels, which split between 40 and 41%

Here’s 41%:

Here’s 40%

Is that a 3d mesh? And Rendered display mode or?
So far here the transition in Rendered mode is pretty clean, no steps like that.
-Pascal

It’s a 3d mesh, yes. That’s rendered mode with ambient occlusion.
Material By Layer Default plus transparency

I see a rather sudden change in transparency here - RH-48566.

Is there any work happening on this bug? I am seeing the same issues here. Please see screenshots below. In our use case, it’s preventing us from showing the resulting view captures to our clients and we have to revert back to rendering :frowning:

Thanks for looking into it!

Rhino 6 SR11 2018-12-14 (Rhino 6, 6.11.18348.17061, Git hash:master @ 600b621e607cf5226a968db60d7ac9230541b94d)

Windows 7 SP1 (Physical RAM: 16Gb)

Quadro K2100M/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 390.77)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-23-2018
Driver Version: 23.21.13.9077
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

For others stumbling upon this, a quick fix mentioned by David in the bug tracker is the following
https://mcneel.myjetbrains.com/youtrack/issue/RH-48566
David Eränen commented 21 Sep 2018 02:56
Actually, there is nothing wrong with the amount of transparency. What happens is that shadows are not rendered on the object if it’s more than 40% transparent. Why 40%? Because that’s what has been set in Tools -> Options... -> View -> Display Modes -> Rendered -> Shadows -> Transparent Objects slider. If you want transparent objects to always cast shadows, drag the slider all the way to the right.

And a quick note on Jeffs comment over at Youtrack

The 40% was chosen because that’s what Sketchup’s default is for a similar option. Now, this was over a decade ago, and many things have changed since then, and I haven’t looked at this feature in probably 15 years. Which brings me to my next point…This has very rarely come up (if at all) in those 15 years since the option was added…so either users are finding the option, or just don’t care about or use Rendered mode with transparency very often.

From a user perspective: Graphics cards became a lot more powerful over those years and the quality of rendered mode in general improved a lot from Rhino 5 to Rhino 6. Only since Rhino 6, we are using -ViewCapture… with a high passes number, to produce presentation ready images. Before those images had to be rendered. Only since then, we are noticing this behavior. So I think, this is not coming up much yet, because users are adopting the new possibilities that Rendered mode in RH6 offers, rather slowly.

Hi Silvano - it looks like action on this is put off till V7 …

-Pascal