Joining or capping tapered surfaces fails

cannot-join.3dm (3.4 MB)
Hi There,
I’m using the the latest evaluation version 5.2.1. I am having trouble joining or capping polysurface objects in the attached file. There are a number of tapered extruded curves (started as letters from a business logo imported from a pdf file) that I am trying to join to an extruded rectangle to make a plaque. Several of the letters were joined successfully using boolean operations but the letters ‘s’, ‘u’, d’ and ‘n’ have me stumped. The problem is that when they are either capped using Cap Planar Holes or joined (after trimming and deleting excess) unpredicted artefacts are produced which are visible as skewed surfaces in Shaded View and lines in Technical View. The lines in technical view don’t seem to be accessible with edit points turned on.
I was able to cap the letter ‘s’ without producing artefacts but the artefacts are created when it is joined.
I have read that boolean operations are better handled manually with trim, delete and join and I have tried that with the same results.
I have also tried the Boss command but it fails silently. The file includes the original curve for the letter ‘s’ so that you can test Boss also.
I am imagining that there must be something flawed about the original curves i have imported but they look ok when i examine them with points turns on. I would be grateful for any assistance you have time to provide.

The Rhino mesher messes up in situations like this where you create surfaces from tangent curves without splitting the surfaces along the knot.

In this case it appears that you can either start with getting rid of the tangency between the curve segments before extruding or cleaning up after extruding with the DivideAlongCreases command with SplitAtTangents=Yes.

To do the former, delete the control points that are circled in the picture below. The black curve is the original one and that will end up like the green one after deleting those points. You can then move 2-and-2 control points to get as close to the original curve as possible.

As for the Boss command, that fails here as as well - also on Rhino 6 WIP. @pascal?

2 Likes

Checking it - thanks!

@julian.de.saxe. @wim - for now, SimplifyCrv before extruding - Boss still fails, however. I’ll see about that.

-Pascal

Thanks wim… DivideAlongCreases worked great for me.