Joining curves again

hiya
I seem to constantly have this trouble, I am trying to join some curves to loft and hour after hour I try and google and try again but nada .

So I have been using intersect crvEnd crvStart etc and then zooming right in to see the join but when I zoom right in what I get is lines appearing apparently randomly. even when I can get an end point to attach to a curve it still won’t join ?

picture 1 is zoomed way in and the point is way off the curve but the join looks good ?
so I grab the point and try to attach the point to the horizontal curve and a second curve just pops into existence ( Pic 2) ?? this always happens on extreme zoom so then I don’t know what to do ?? the line end locks to the new magic line and then the magic horizontal line vanishes again ??

Hello - what is the thing you’re trying to do though, join the curves? Or just have the endpoints coincident, or? If you zoom in far enough, you can generally get the ends to look ‘off’ (though I think @stevebaer did some work in this area in the last SR or two to make it less apt to happen, in V6).

GCon will tell you how the ends are - compared to tolerance - what does that say about your curves?

-Pascal

Hi @pascal

I am making a frame to loft so need to join the ends to the base curve, using GCon i get ‘Curve ends are out of tolerance’ but zooming in to fix it goes bad when magin lines appear so I get confused on what to join to ? I take it this is a known bug ?

Could you post the 3dm file, please?

Have you tried using Match to align the ends?

hiya
here ya go, I just looked at Match thanks @davidcockey and some real weird stuff happens :slight_smile:
sample join probs.3dm (42.1 KB)

Match only works between the ends of curves so it won’t solve your problem.

GCon only works between the ends of curves/polycurves so it is not appropriate for your curves/polycurves as configured.

@fragged8 I’m guessing you may be slightly confused about joining in Rhino. The Join command links individual curves together into a single polycurve. The end of one segment needs to be at the same location (within the absolute tolerance) of another segement for the segments to join. Curves cannot be joined with one part of a curve branching from the middle of another. Join also works similarly with surfaces. https://docs.mcneel.com/rhino/6/help/en-us/index.htm#commands/join.htm?Highlight=join

First step: Explode what you have already joined together, and then join the segements of each section but don’t try joining the segments into a single assembly.

Comments below are based on your curves as they existed in your uploaded file:

Are you trying to use the Loft command? If so your curves as they exist won’t work with Loft, or at least won’t give a reasonable result. The usual input to Loft is a set of sections which don’t intersect (or ends of the curves intersect). https://docs.mcneel.com/rhino/6/help/en-us/index.htm#commands/loft.htm?Highlight=loft

Your curves look like they would be more appropriate for input to Sweep2 if they were split into rails and sections. https://docs.mcneel.com/rhino/6/help/en-us/index.htm#commands/sweep2.htm?Highlight=sweep2

You could also use NetworkSrf if the curves for each shape were split into two sets. https://docs.mcneel.com/rhino/6/help/en-us/index.htm#commands/networksrf.htm?Highlight=networksrf

If you want to have curve ends meeting in one single point have a look at “Connect”, “Trim”, “Split”, or “Fillet (with radius=0)”

everything confuses me in Rhino @davidcockey just when I think I got it then another problem crops up and messes me up. There should be a stripped out version of Rhino for us canvas guys.
I don’t need super fine tolerances, everything I am doing is for making fabric panels but the time I am spending in Rhino is really not worth it. It just takes forever when I could stick a piece of plastic on what I need to pattern and have it done in 5 mins.

You can change the tolerance Rhino uses for determining when “close” is “close enough”. Start Document Properties, then click on Units. Enter your desired tolerance under units. If you are using millimeters for objects which are several thousand millimeters in size and you don’t need more accuracy then an absolute tolerance of 0.01 or possibly 0.1 is appropriate.

However the problems you had with your curve network where not fundamentally due to tolerance issues. Rather they appear to be related to what you were trying to do with the curves. Have you gone through the User’s Guide tutorials and Level 1 and Level 2 training materials?

Cheers @davidcockey I did know about tolerance settings and I will have another look, don’t mind me i’m just getting frustrated with Rhino taking me 1000% more time than I could do manually.
(edit: tolerance must have reset after updates to 1thou so have gone back to 0.1 , will have to keep an eye on that )

I have been through the tutorials but being over 50 now I need to do it every day :slight_smile:

up to christmas I was getting on ok and have made some actual cover this way and not a bad one yet, since xmas I think i’ve take a backward step, I have begun to get some lofts going now after splitting the curves up into separate sections so making some headway.

thanks for your help .

Richard

this is pretty much where I was trying to get to, now i just need to trim and join the lofts.