Joining a revolved surface and a extruded surface


#1

I am having trouble with creating a smooth surface when joining a revolved and extruded surface. The surface does not seem to match up and there is a small gap when looking at it in rendered mode, even when toggling the mesh render settings to slow.

I have tried trimming the surface and blending it, but when I try to join the surfaces, the ‘crinkle’. I have been trying for a few days and am not sure how else I should approach making this volume, any help would be appreciated, thanks!

I’ve attached the file here if anyone is willing to give it a shot. One side is an attempt to blend and another is just joined without blending. Thanks!pill shape tray.3dm (211.4 KB)


(Pascal Golay) #2

Hi Gushingg - the surfaces are tangent at the simpler end - that is OK, no gap, just a change in curvature - you can make it look cleaner by changing the meshing settings in DocumentProperties > Mesh page to Custom and set ‘Max distance edge to surface’ at say .01. If you want it really smooth, the ends cannot be arcs (revolves) they’ll have to be a little more complex and be curvature continuous with the straight part.

-Pascal


#3

Hi pascal, what method should I be using to make it curvature continuous? And what method would be the best? Do I have to change the way I construct the line work and structure? I am always having trouble with surfaces like this and would like to get better at making such surfaces. Thanks!


(Pascal Golay) #4

Hi Gushinngg - the blend might work, but I think you may want to modify the profile curve so that it has a zero-curvature at the center of the object - since you have a zero curvature segment (the extruded part) you’ll get a clener result, I think if the curved part also straightens right at the center of the revolve as well:

That will help it in the center, then I think making a transtion surface to the revolved part may be a good way to go (blue surface):

Something like this, maybe -
pill shape tray_PG.3dm (68.8 KB)

-Pascal


#5

Hi pascal, thanks for the help so far, but just two more questions

Firstly, wouldn’t there still be a slight discrepancy since it is revolved and joined to the extruded surface?

Secondly, what if the profile is not allowed to have a flat surface in the middle?

Also what is the cause of the weird surface between the two pieces?


(Pascal Golay) #6

Hi Gushingg - the idea is to have the middle, blue surface act as a G2 blend so that it is curvature continuous with the extrusion at one end and with the red revolved piece at the other. If the profile cannot have a flat, then the join cannot be curvature continuous at the very center - the revolved surface will have non-zero curvature at the center - that may or may not be a problem in real life.
Making a transition that cuts off the center of the revolve, as you had in your original file, is another approach of course - that might be fine too - I think it maybe needs to be a little deeper on the outer edges than you had it - maybe a little bit dog-bone shaped.

I get this for a Zebra on the example I made:

-Pascal


#7

Ah that explains a lot about the surface issue, thanks! Guess I will have to practice blending more.

The zebra is really different, could there be something wrong with my settings? Why does it look so smooth on yours?


(Pascal Golay) #8

It’s possible - I joined the surfaces and I always adjust the mesh for Zebra and all of the analysis modes to make a very fine analysis mesh - a quick and easy way to do that is to set minimum initial grid quads to a large number, like 5000…

(Do this for analysis meshes only, it would cripple the display to have such fine settings on the display meshes)
-Pascal


#9

Oh, that helps smoothen the zebra out a lot, however the surfaces still do not match up. It the issue only is on the red surface for me.


#10

I’m not really sure if this what you are complaining about, but if you look at the render mesh (extract RenderMesh) there are a few long skinny triangles that disrupt the light reflections.
If you adjust the “Maximum aspect ratio” in the mesh settings that may get the appearance you want.