Issues with Rhino 6

Thanks for the additional information. I’ll keep poking at it and keeping an eye out for other reports of this behavior. If you see any pattern, please let us know!
-wim

1 Like

hi @stevebaer , so i downloaded the release candidate and had a go. i must resume version 5 is still faster in several points.

basically all viewport manipulations are a bit slower than in version 5.
especially zooming feels really noticeably heavier, it feels like the difference between my old 2009 macbook pro to my newer computer now in version 5. that is particularly bothersome for me personally because i was longing for that snappy feeling, which i now only have with version 5. anything you are still going to change? its not that i used an enormous amount of objects, basically just 448 copied and moved cubes.

dragging objects is now also slower. it seems to wait for that pop up (which for drag one would not need and cant access anyway i think) and this pop up now takes a little longer, delaying the movement and making the entire experience working in rhino laggier. its not a lot but its definitely enough to become distractive.

technial view seem now a bit faster, but compared to rhino 5 its still a little slower.

What kind of results are you getting with TestMaxSpeed on this model?

@stevebaer

Rhino 5 in average
Time to regen viewport 100 times = 0.61 seconds.

Rhino 6
Time to regen viewport 100 times = 1.48 seconds. (67.75 FPS)
Command: '_Paste
Command: TestMaxSpeed
Time to regen viewport 100 times = 0.99 seconds. (100.81 FPS)
Command: '_Paste
Command: TestMaxSpeed
Time to regen viewport 100 times = 1.02 seconds. (98.23 FPS)
Command: '_Paste
Command: TestMaxSpeed
Time to regen viewport 100 times = 1.45 seconds. (69.01 FPS)

oh and by the way the results of commands are not shown anymore, only after clicking on the symbol.

Hmm… you’re getting well over 60 FPS. If view manipulation feels heavier, there must be something else going on. I don’t know what this is as at the moment and am not entirely sure what would be a good way to test things. I’ll have to think about it.

hey Wim:

it might be important to add that i am using a standard mouse with incremental scroll wheel. its as i pointed out particularly noticeable with zooming. the steps of the mousewheel feel like they need longer to complete. the difference is not huge but enough to make it feel slightly chewier. rotating the viewport seems very similar as in 5 if i dont want make up the difference but it feels just a little bit faster in 5. to be fair the more often i change between 5 and 6 the more often i am beginning to believe that i am getting crazy, time for a good night sleep.

3 more things which i collected:

1
the viewport has some odd behaviour, after working a bit and changing the viewports i suddenly end up with this, which not only happened a few times but also transmitted itself into rhino 5. once even so persistently that 4View command only helped after using it multiple times from each viewport individually. and it seems to move the viewports every time the exact same way. since i rarely shift them around i cant even remember if i ever moved them that way once at least not in rhino 6.

2
switching between 5 and 6 messes up my inspectors in rhino 5.

3
that may concern @nathanletwory
everytime i switch to raytraced i get a beachball forever, i cant do anything anymore besides force quitting. artic works though. i even get an instant shut down trying to switch from a mixed viewport style in one viewport to ray-traced. could not get it going once. it shows the viewport with ambient occlusion which looks ready but then it beachballs. i read that it might need a few minutes to compile something, (why its supposed to be doing that is also a bit strange to me) but i left it even for something like 10 minutes once and it never stopped.

Seeing the GPU configuration in your first post:

  • no CUDA support on the Mac for Raytraced.
  • you don’t have a supported AMD card for OpenCL - nothing is being compiled
  • you’ll be using Raytraced on the CPU
  • if you’re doing a complex scene in a large viewport it will take a long time for anything to appear. Things to fiddle with in advanced settings:
    • RhinoCycles.DpiScale - higher number means less work to do. Blocky in viewport, but _-ViewCaptureToFile will always render at value 1. On my MPB I use 3 or 4 for even the slightest hint of ‘interactivity’
    • RhinoCycles.UseStartResolution (set to true)
    • RhinoCycles.StartResolution (set to some power of 2, say 32 or 64)
    • RhinoCycles.UseFastDraw (set to true)

thanks for the imput, thats a pitty, since the computer is not very old and still pretty powerful, rendering on cpu is a real bummer… any plans here or do i have to throw my computer away and run with the newest?

i tried all your settings and have RhinoCycles.StartResolution set to 64, better more or less what does that mean anyway? but the issue remains, as soon as i switch to raytraced i get an infinity beach ball. forcing me to force quit rhino. i wonder why arctic works, does it not also use raytraced?

edit: by the way when i switch to raytraced i get this in the bottom of the viewport, its not readable, maybe due to the dpi settings? i enhanced the colors here and scaled it to a “readable” size.

@nathanletwory

is there anything at all i can do to get ray-traced working? as written above arctic works already and i found that i can change the settings in the display mode that it shows the rendering material. so why does it not work with raytraced? i also set the same lightning system to ambient occlusion, everything else seems the same but as soon as i switch to ray-traced Rhino goes to the beach not coming back…

here another request or idea, would it be possible to deactivate the ambient occlusion or the virtual ground plane while rotating the viewport to speed it up? it seems to slow it down significantly. or is this maybe just on my machine noticeable?

Just to answer this question - no:
Arctic:
image

Raytraced:
image

1 Like

@encephalon I’m not sure that running 10.14 with this card is a good idea, my girlfriend has the same laptop, and as there are no official drivers from NVIDIA, it is much less snappier than on High Sierra.

@nathanletwory what do you mean there is no support for CUDA on macOS?

https://www.nvidia.com/en-us/drivers/cuda/418_163/macosx-cuda-418_163-driver/

It just requires 10.13, and it seems you are stuck on that forever, upgrading to Mojave is not a wise decision, rollback was a nightmare to me, when I naively did it on my desktop.

1 Like

Copy/paste does not working

For Raytraced no CUDA support no. We have our Mac machines all on 10.14, and I wouldn’t be surprised some will be rolled to 10.15 whenever the time is there.

that was it when we tried to get CUDA working on the MBP with NVidia GPU.

@nathanletwory sorry if i keep bothering you, but i feel a bit left out here, is there anything i can do to get raytraced working at all? is it a bug or is my chip not working generally? i avoided spending too much money so i went with a later model, but when people say that the nvidia is not supported with mojave, do you think that AMD R9 M370X would work with raytraced? i found a model from 2015 which is not too expensive and might switch it.

Not sure what to say. I render on my MBP using the CPU only. It clearly isn’t fast by any means, but it should work. So you’re saying that even the simplest scene never starts rendering? I.e. just a torus or box?

Here a fairly large model polygoncount-wise

And this is what I am on

kuva

Make sure that in Preferences > Cycles your render device is the CPU.

The theory is that the AMD GPU you mentioned works - I think we have an MBP with AMD GPU at the office, and that one I know does work. But I’m not that fluent in Mac, so best to get some opinion from a user who does.

yup even a simple cube with nothing at all never starts rendering raytraced in the viewport and knocks Rhino out. i left it once for 30 minutes but it never recovers. so you say it should actually work? so switching computer to a radeon chip may not be necessary?

Did you already ensure your rendering device is set to CPU?

1 Like

hah… i feel embarrassed i promise i switched that on and tried both, but this time i quit rhino before trying cpu again… and what do you know… works now

thanks @nathanletwory

Wohoo!

1 Like