Issues with Neon viewport captures


I can’t seem to capture an accurate rendition of a Neon render using the various view port capture commands. The renders look great in the view port themselves, but are all washed out when using the view port capture commands. If I just use the snipping tool in Windows to capture the view port, they look fine. Is this user error? I’ve looked through the posts already on the forum, but unless I missed it, I didn’t see one regarding this issue.

(Andrew le Bihan) #2

You should be getting the exact same thing - and as this has never come up before, I’m at a loss to explain this.

(John Brock) #3

I was unable to get a different image between the viewport display and ViewCaptureToFile. I tried several different image types and they all look just the same.

(Wim Dekeyser) #4

Well, I’ve reported earlier that while I get edges to render in the viewport, when I then save the image to file, the edges are lost. Not necessarily the same issue, I suppose, but close enough :wink:


Hmm, I’ll play around with it some more and see if I can discover anything. It’s not a huge deal, I can still take advantage of Neon for good ray traced feedback in Rhino or if I don’t feel like going into Keyshot for a quick rendering. If I come across any new info, I’ll post it.


I have it figured out, and it’s a setting and/or user error (dang it). In my “Raytraced with Neon” settings, I had the background set to “Transparent”, which gives me this:

If I change the background setting to “Use Render Settings”, I get what I’m expecting:

Regardless of the these two settings, the look of the image in the viewport is the same, but are very different when trying to capture it to a file. Maybe my mistake will help someone else, at some point.

(Andrew le Bihan) #7

Ah yes - this is a bug that is actually fixed in house. Well done for figuring it out!


Any Idea when this will be fixed? It would save a lot of time manually clipping out backgrounds.