Issues with graphics of Block/polysurface

I have issues with the graphics of my polysurfaces, that have been blocks, created originally in Sketchup, imported to Rhino. Do I have to re-draw everything, to solve this issue, or can anyone recognize this??

It also comes up as an extra geometry when trying to render in Vray…


Thank you,

Dennis

Here is a file of the issue (probably only shows on my computer…)
Polysurface issue.3dm (8.0 MB)

Your geometry is extremely far from world origin. Please review Objects Too Far From the World Origin [McNeel Wiki]

1 Like

Yes, your right @nathanletwory ,though not the main issue i’m afraid.

I’m suspecting the issue is the block/import from sketchup. If everything is exploded into the smallest pieces, and all blocks removed, then it is solved. -This would take an eternity for the whole project though, so if anyone has had this issue before, please share your thoughts.

Best regards

Actually, you should be able to just run _ClearAllMeshes, then switch back to Shaded mode.

That said your object is very far from world origin, at least Raytraced will not be able to draw it properly, since it can handle only single precision floating point numbers.

Compare:


With

Wow, that actually worked. I have colleagues who fought this issue forever.

Thank you very much!

1 Like