Issues with draping an offseted surface

I am a newbie with Rhino for Mac. I was trying to reproduce my colleague’s works with Rhino 4 for Windows. First, I imported a STL mesh file and centered it. Then, I offseted mesh by 2mm outward and I used drape to create a surface.
The problem was that draping in Rhino for Mac would not respect the new offseted mesh, i.e. the draped surface would be on the original mesh, not the offseted mesh. If the original mesh was deleted, the draping would fail to create a correct surface. It was not an issue in Rhino 4 for Windows.

I followed the same sequence of steps here and it worked as expected in v5.1. Can you post the file with the two meshes and indicate which direction you’re draping from?

I dropped from the top view. I could show the screenshot here. If I draped from the bottom view, it still failed.

Drape function worked just fine without offset the mesh. Anyway, I ended up offsetting the mesh first and turn the mesh into NURB surface. Then, draped on the polysurface.

Ps. I can send you the STL file by email, if you need to take a look at the original mesh.

That would be great thanks…

At a guess, I’m thinking the offset caused some self overlaps in the mesh which Drape couldn’t make sense of. I’ll make sure the issue gets filed to hopefully improve the command in the future. Thanks!