Issue with Mixed Display Modes

I am trying to create an illustration of this that I want to show in context without being totally obscured.

I have the rendering in shaded. I used setobjectdisplaymode to set the surrounding objects to X-Ray. But as soon as I turn the layer containing those object on, the object I wanted solid turns to X-Ray as well.

Even if I use set object displaymode to shaded for my “solid” object, it still comes out X-ray when the X-ray objects are on.

Any way around this?

It’s impossible to say without your file.
Can you please post it and any specific settings you are changing to see the effect?


Hello - so far this does not happen in my test:


I am using the default X-Ray and Shaded settings. I have since discovered this does not happen with Solid/Ghosted.

I could be a hardware compatibility issue.