Issue Importing IFC with VisualARQ

And yes , VisualARQ was loaded before I started the import

Hi Loïc,

Could you send the second ifc file you mentioned (the one that make the program crash) to visualarq@asuni.com ?

Thank you

Hi, I have a recurring issue with importing IFC’s. Quite often objects are not trimmed it appears:
image

Is this related to Rhino’s mesh boolean and mesh trimming bugs?

While in Solibri:

I’ll send you the IFC @RamonC

@Holo, this issue has been fixed in VisualARQ 2.8.3: VisualARQ 2 - Version 2.8.3 released

1 Like

Hi Francesc - I too am having issues with IFC files…many issues.

These are received from a variety of companies, presumably also produced from different programs. Here are just some of the problems I’ve been having:

  • IFCs hang at the point of “building geometry”
  • Hangs/crashes whilst saving the file as IFC
  • Hangs/crashes when trying to copy to clipboard
  • Some objects (eg slabs) disappear when copying into another open Rhino session, whilst others are fine.
  • Objects lose their properties on import

There are others but these are the most frustrating ones. The whole process of trying to do even simple things with IFC files is very difficult. Any advice?

Hi @Ben_B, we may require the IFC file (or the 3dm file you are trying to export to IFC) to see if we can reproduce all these issues, analyze what’s happening and fix anything we can do on our end. Please send the files to visualarq@asuni.com

Thank you Francesc, I have emailed you.

Hi @fsalla

I still have trouble importing IFC’s with correct holes in them. And this really needs to be solved so it can be used reliably. And these holes you see missing here are rectangular holes in rectangular walls, so it shouldn’t be too difficult for Rhino’s boolean tools to fix.

Solibri:

Rhino:

Hi @Holo, can you provide the ifc file please? you can send it to visualarq@asuni.com
That way we can figure out what’s happening.

Yes sir,
sent you a mail, please check to see if the link works, if not I’ll send it via wetransfer.

Hi @Holo, we have fixed this issue in VisualARQ 2.9 version. VisualARQ 2 - Version 2.9 released (for Rhino 5, 6 and 7)

1 Like

That’s only halfway there Francesc, but still no cigar…

And make sure you track the errors internally so you can report that it fails. I can only imagine the frustration for your users when they discover that VisualArq skips important building information without letting anybody know.
THIS IS REALLY IMPORTANT!!!

Hi @Holo that’s strange, I got a little better-imported model but still see some gaps and windows whose material is wrong… But I see we don’t have exactly the same model. Please send me that new one, and we will dig a bit further.

Thanks, new file on the way.
And PLEASE inform them on the need for a bug list + add a TextDot with an exclamation mark (!) on the places where it fails. Reporting bugs is even more important than getting everything right IMO, but it needs to get everything right to be reliable of course.

Thanks! I’ve got the new file, and everything looks quite correct.

Are you using VisualARQ 2.9? (Make sure you have the public version: http://www.visualarq.com/download/update/)
What Rhino version do you have?

Strange… I just upgraded to the latest this morgning and I have Rhino 6sr 30.
The file was imported to another file, could the local tolerance f*** things up?
(We always use I meters and I have it at 0.001. (1mm) )

If so I guess you should add a custom tolerance to make sure IFC has a good enough tolerance.
As we HAVE to be able to import IFC’s into other files and still TRUST that what we get is the correct data. I can not stress enough how crucial this is :slight_smile:
Cheers

Finally getting some results for you:
I just tried opening the IFC in Rhino and let VisualArq set it’s own settings (mm and 0.01 as tolerance) and then it gets the windows right.

I also tried changing my tolerance:
0.0001 meter fails
0.00001 meters (equals to 0.01 mm as you have) also fails.
But setting it to mm and 0.01 WORKS!

Go figure! What’s the difference between 0.01 mm and 0.00001 meters?

So we are getting closer to the issue here.
I’ll update my template, but please do everything you can to make it robust so importing it into existing files works just as well.

Setting it to 0.001 mm gets some of the internal windows holes right too:


As you can see in your image the two lover left windows are not punched through:
image
One of these got fixed by uppint the tolerance to 0.001 (But only one)

I don’t know, but this might be linked to Rhino’s age old coplanar-face-boolean crappyness :slight_smile:

Yeah, we are getting closer! thanks for these details.

How is that you had the tolerance to 1mm?
The model you sent me has the Absolute tolerance to 0,01mm.
How were you opening the IFC file before? dragging the file into Rhino viewport? Through Import command? Through Insert? Just Opening it?

In any case, I think the model should look right with a 1mm tolerance. We don’t recommend using a smaller one, since the calculations become far more complex and this affects modeling performance. In architectural projects, it doesn’t make sense to have more accurate precision.

Hi, I usually drag it in and use import if the file is small and I need it’s content.
On large files like this I make a new file based on my template (Which has a much more sane render meshing setting than yours to be frank, at least for my needs) and then I import the IFC by dragging it in.

And this is what I do with it after that:

I have a script that mesh the objects (since extract render mesh uses a different meshing engine that is overly complex too) and then I join all meshes based on render color.

That way I get a super light and responsive model that I can snap to and use this as an xref in the actual project with out hogging all resources.
This workflow works very well for my needs (when the model works that is… :wink: )