Isolate object?

Any chance we can get ‘Isolate Object’ as an RMB dropdown option we an object is selected? IE, everything else gets hidden except for the selected object. Would really love this shortcut…

cheers,
-d

do you use the popup menu on the middle mouse button (or other)?

if so, it includes the invert selection & hide macro by default…

Hi David - You can macro the dash-Hide command as well - this allows the use of ‘hide buckets’, basically named sets of hidden objects

! _Invert _-Hide "Isolate"

to isolate selected objects

! _-Show "Isolate"

to show just the objects hidden above

The Hide A/ShowA menu entries also use dash-Hide in macros.

-Pascal

3 Likes

I’m just using the default Right Mouse Button popup. How do I access the Middle Mouse Button popup on Mac? I see the preferences give different popup options for MMB, which is cool, but I can’t figure out how to even access the MMB. I figured it would just be cmd+RMB or some other combination, but that’s not working. I guess it’s a user error :grin:

A modifier key that brings up the middle mouse button menu would be awesome. I didn’t even know those menu options existed. I may have to invest in a proper mouse for CAD!

@dwalden @decibelguitars
i think if you guys are using a magic mouse, you’ll need a 3rd party utility in order to get middle mouse button functionality… something like:

http://magicprefs.com

it’s free… i’ve used it in the past for trackpad customization but i no longer need or use it… i don’t know how to use it with a magic mouse but i believe it’s the way to go other than getting a mouse with a dedicated MMB.

the popup is actually a tool palette and i mistakingly said ‘popup menu’ in my first post… basically the same thing from a use point of view but for clarity, it isn’t actually a menu.

Hi Pascal, I’m having difficultly setting up this shortcut as well. I tried to set up an “Alias” but the commands won’t execute… see here a screenshot of the error message. I tried variations including “_Invert_Hide” , “!_Invert_Hide” , “’_Invert_Hide”. error screenshot

Hello- you need spaces between commands:

! _Invert _Hide

But the macro I suggested above a few posts is a better ‘isolate’ than Invert Hide.

-Pascal

1 Like

worked! Thank you.