Isocurves vanish on orbit

Isocurves of selected geometry vanish on orbit.
See here:

Bus 002.3dm (3.5 MB)

Rhino 7 SR14 2022-1-4 (Rhino 7, 7.14.22004.01001, Git hash:master @ e3d354475c9d642213575609786a4b35ea48ca22)
License type: xxx, Build 2022-01-04
License details: Stand-Alone

Windows 10.0.19044 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2070 (NVidia) Memory: 8GB, Driver date: 11-26-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 497.09
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-26-2021
Driver Version: 30.0.14.9709
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\XNurbs (80be33b0-13b2-4ac4-9c77-03829214f9e9)\5.2.0.0\XNurbsRhino7.rhp “XNurbs”
C:\Program Files\SimLab\Plugins\SimLab 3D PDF From Rhino 6\plugins\SimLabPDFExporter.rhp “SimLab PDF Exporter”
C:\Users\Charles\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\IntelDenoiser\0.6.4\IntelDenoiser.Windows.rhp “IntelDenoiser.Windows” 0.6.4.0
C:\Users\Charles\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\raytraced-blend-material\1.5.0\RaytracedBlendMaterial.rhp “RaytracedBlendMaterial” 1.5.0.0
C:\Users\Charles\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\raytraced-materials\0.1.5+v7.4\RaytracedMaterials.rhp “Raytraced Materials” 0.1.5.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.14.22004.1001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.14.22004.1001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.14.22004.1001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.14.22004.1001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.14.22004.1001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

@pascal
@jeff

Pascal, perhaps the display master should know about this.
But I don’t remember who it is… Jeff?

Hm… not seeing this so far here - does this happen in any file or view? How about in wireframe?

-Pascal

I can see the effect in Semi transparent only.

I’m not seeing here either with the provided file…

@Charles Please make sure you can duplicate the problem with the exact file you posted here. I know that might sound strange, but sometimes users will get something to happen, then save their file to some “test” file and send it off…thinking that the file they just saved will show the problem…but never really verifying that they can reproduce the problem with said file… So, please download and test your own file to see if it happens.

Also, by “semi transparent”, do you mean Ghosted display mode? If so, is your Ghosted mode at its default settings, or have you made any tweaks? If you’ve tweaked settings, then please export your display mode(s) that show this problem and post them here.

It looks like this might be a near/far clipping plane issue based on when/where the isos turn off and on… Unmaximize the view, and with the view still active, run ShowCamera… This will display a crude wireframe of the camera’s frustum in all views. Now try to repeat the problem and take note of any changes to the camera icon (in the other views) when the isos turn off and on.

Note: Run HideCamera to turn off the camera icon.

Thanks,
-Jeff

Hi Jeff

Doesn’t sound strange, it is a highly important point.
I already did so before starting the topic.

I’ on a German Rhino right now, I didn’t remember the correct term.
I think Ghosted is right.

Oh, I wasn’t aware of a non-standard setting, sorry.
The altered setting is exactly about isocurves.
Perhaps this is the root of the problem.
I should replace vanish by appear in the topic title…
Halbtransparent.ini (13.3 KB)

See here for camera etc:

Bingo! The “Show isocurves” setting in Ghosted mode is what’s causing this. I guess I should have noticed they were turned off in the non-selected state… Selected objects are apparently showing all isos and edges in certain cases but not others. Note: It appears all modes will behave like this if/when isos are turned off.

I guess the question I now have… What should the behavior be? If you’ve intentionally turned off isos, do you expect them to turn on when selecting an object? Or should the display remain the same, and the object is now just “highlighted” ?

@pascal What say you?
-J

I’ve wondered about this as well. I guess more often than not, I wish iso display respected the general display mode settings on selection.

-Pascal

@pascal Ok, that’s what I would have expected as well…

Can you YT this, using this thread and example as reason for why this should be… Fixing it will automatically fix Charles’ issue…stick it on my list.

Thanks,
-Jeff

1 Like

Yep.
RH-67008 Display: Selected objects isocurve display

thanks.

-Pascal