Is this hole or empty space after sweep condition can be modeling?

big space at the edge

more better with more control points , less space around the edge

add more slash , almost no space around the edge

should I do with more slash ? to deny the hole space at edge, to print modeling ?
or even with space at edge, we can also print out 3d modeling ?

please help with my newb question hmmm :frowning:

Hello - this appears to be the display mesh being too coarse for the view - please see http://wiki.mcneel.com/rhino/meshfaq for more info and some help on making things look better.

-Pascal

thx Mr.Pascal, so we just set the surface to fine in max distance edge to surface setting when we are going to 3d printing only ?

while in design progress, we just sweep or loft the surface like that ?
please , thx :slight_smile:

What you see on screen in shaded views is not a reflection of the accuracy of the surfaces - the wireframe view is a better indication of that. In any case, when you are ready to print, if that is the goal, you would Join the surfaces - this will ensure that the meshes match cleanly across joined edges - in any case the mesh you generate to print (Mesh command, for example) is not controlled by the display mesh - they are separate.

-Pascal

wow , thx for your quick reply , this is good forum :slightly_smiling:

hmmm.3dm (1.2 MB)

one this problem again hehehe :stuck_out_tongue: why I cant boolean union this 3 polysurfaces , hmmm … thx

I’d Union the parts as solids first, then cut with the planes (Trim then Cap or Boolean2Objects)

<a class=“attachment”

hmmm_PG.3dm (1.5 MB)

-Pascal

hmmm i see, after i union solid all parts(not only 3 polys, same things more than 100 parts), some polys become less detailed, the surface of poly view a crack hole,

it is the union work will make all polys surface degree decrease ? so less detail no smooth , because i work like Mr.Pascal recommend, hmmm

No, boolean unions will not decrease the quality of the surfaces. They will force the creation of a new display mesh and, depending on the settings, that might show a less smooth surface. You will need to carefully read the document that Pascal pointed to before: http://wiki.mcneel.com/rhino/meshfaq (and also the The Curse of the Polygon article that that document links to).

That sounds like the surfaces are not joined. Also this is explained in that Curse of the Polygon article.

thanks for the reply Mr.Wim, I am trying again with Mr.Pascal’s idea, is the max distance the edge to surface setting is in mesh command option ? or in setting option, because i dont see and what parameter to set …

i thought during we design , no need to set it yet first, since we want to print 3d out modeling we set the detail surface setting right ?
thx, i know this is so newbee basic question i am the only person ask, haha, really i need the basic understanding , because i only learn others (had learn about 1,5 year, by video youtube, i am design ring of superman style model characteric, about 70-80% done, if nothing others addition design ), thanks i still need much learning from all, specially thx for Mr.Pascal and Mr.Wim, salute :slightly_smiling:

The mesh settings will take some experimentation - it is rather model-dependent.
So yes, for now, mostly worry about getting the model right - which for 3D printing means making sure you have a closed polysurface. When you are done and will export the mesh, start playing around with the mesh settings.

Yes sir Wim :slightly_smiling:
excuse me again,
with this quality donut decreasing is it no problem ? still can continue union all donut and cylinder polysurf ? (right side after union with cylinder, left donut is not union yet) is the quality still the same with before union ?

hmmm.3dm (20.0 MB)

big thanks, hmmmm -.-

motif.3dm (2.3 MB)

for comparing the right and left donut quality

As it was said before, what you see in shaded mode is not a good indication of the quality of your model.
Look at the isocurves on your surfaces; they are perfect.
As Pascal said, if it bothers you, work in wireframe view.
Or adjust your Render Mesh quality as explained here: http://wiki.mcneel.com/rhino/meshfaq

thanks Marc, Got it , hehe, sorry i am so late,

So, yes, the quality is still the same before and after the boolean union.
That said, I think that you should either tighten your tolerance a decimal (or scale the geometry by 10 until you are exporting the final result) and you should probably try to work with cleaner geometry. You only have revolved and extruded circles in there and the rings and cylinders should reflect that. In this picture, the blue is your geometry, the red is simplified geometry.

okay Mr.Wim, i will do more cleaner geometry,

and with larger scale first, then smaller scale in smart flow step on ring body surface