Is there a bug with the sweep1 component in R8?

I’m following a fairly simple tutorial.
and at the stage of doing a simple sweep1 from 2 closed profile curves and a circle, I get an error when there is no reason I can see for an error [I baked the curves to test if it show an issue sweeping1 in Rhino, and these curves sweep fine.
is there a bug with the sweep 1 component in R8?

Here tested with just the profiles and the circle [copied from these baked curves that sweep1 fine in Rhino]

image

sweep1 fails.gh (4.5 KB)

[ that’s the tutorial mentioned above]

hi @Akash I see that, fails in Rhino 7 as well.

I’ll add it to the tracker, in the meantime, you can use the attached script
sweep1 rhinocommon.gh (20.1 KB)

RH-78982 Grasshopper: Sweep1 fails

Hi @Gijs

your script worked well until I changed a curve down stream,
[just changed one of the profile curves, and now it give an error.
even when I undo until the point where it worked, it still gives the error
[as if it needs a reset…?]

Edit: once I internalized the curves it came back from the error, so it looks like it needs some kind of a refresh after input changes…? [just guessing here]

image

I don’t see that here. If you have steps to reproduce that I’d like to know.

I’m not immediately able to reproduce…

Maybe it was due to flickering in the wifi link between GH on the built in display, and Rhino on an iPad [with side car]
I’ve had some other non reproducible strangenesses lately

thanks a lot

hi @Gijs
here it errored again [while continuing with the tutorial, at the point of making the cluster

ring size and profile cluster.gh (20.9 KB)

but then once packing the cluster, it refreshed and is now working again

that looks normal to me, since you are connecting ‘empty’ inputs, that only become active once closing the cluster and adding inputs

then it’s good.
[Just that in the tutorial the sweep component was orange like the others [not giving a red error ] But it’s working so it’s great to have
thanks a lot