Is it possible to place a sheet over a table (box)?

This yellow sheet is falling like a solid plate. If I enable softbody nothing happens anymore, it stay on his place. I tried to get a sheet over table effect.

Softbody physics work with meshes. Switch to shaded or another mode that draws meshes.

1 Like

Here I tried it but the solver is extremely slow. Is anything fine with the setup? Could it be possible to get multicore support for the solver? My CPU (2950x) is running at 5% only.

Bongo 3 Sheet-test.3dm (213.4 KB)

I tried a 100x100 polygon sheet but it was to much for the solver. So I tried 10x10. The solver works, but I don’t get a collison. Did I miss something?

Would it be possible to simulate a table sheet with a much finer resolution?

Bongo 3 Sheet-test 001.3dm (224.4 KB)

Here an other test - if I enable softbody than the sheet is falling through the box. Also if I set the Physics Mesh Quality slider at maximum than Rhino WIP crashs during the next solving.

Bongo 3 Sheet-test 002.3dm (36.3 KB)

Do you need this animated or do you just need the resulting mesh?

The resulting mesh for rendering. But general it could be nice to get the animation usage also working.

Joshua meant you have to use any Display mode other than Wireframe (Shaded, Rendered, Ghosted…) to see the soft body in action.


The wireframe stays put. The ‘meshes’ will drop.


BTW It’s nice you are checking out Bongo’s WIP. It’s not perfect… yet. :grinning:

@Luc Thank you, it makes fun to check the new promising functions. Looks like it will be a big step forward. :slight_smile:

I did what Joshua suggested, but at my side I don’t get a softbody collision. Softbody disabled - it works like expected, solid collision. Softbody enabled - no collision anymore.

Did you make the ‘table’ Physics enabed?
In order to keep it in place (imobile) you also have to enable Kinematics.

@Luc Could you please look at my posted files? Maybe you see what I have overseen. Physics and kinematic are enabled for the table. And it works if I don’t enable Softbody.

Model Units is the key.
All your models are in ‘Millimeters’. When you change the Units in your “002” model to ‘Meters’ without scaling (pick “No” in the dialog): Bingo.

You can also try in Centimeters, but then the cloth kind of drips off the table.

Bullet (the basic for Bongo’s Physics) operates in meters. @Joshua will have to take care of this.

Have fun.

1 Like

@Luc Great, now it works here too. Thank you.