Invisible lines in multiple views

I have a bunch of topography lines. But in arctic view some of the lines disappear (also happens in artistic and pen view). Below you will find screenshots of the different views.

shaded view:

In this shaded view everything looks as it should

Arctic view:

In the bottom right lines are clearly invisible. The lines exist as I am able to select them. The view is perspective, but the lines are also invisible in other views such as top view.

If I place a big surface below everything, the lines suddenly appear again.

I don’t have any custom display options, they are default. Do my question is why is this happening and how to I fix it so that the lines won’t be invisible?

Check the appearance of a ground plane.

Could you elaborate? I don’t know what this means?

Check here:

or here:

Thank you. Turning the ground plane on and off multiple times worked for some reason. I left it on off.