Invalid license on first installation


Just downloaded Rhino for mac and have tried to install it a couple of times with the key provided by email but I get “The rhinoceros 5 license XXXX-XXX… is invalid”. I’ve tried with and without hyphens just in case, copied and pasted and trimmed any leading spaces, typed it in manually, etc and it still says it’s invalid.

Has anyone else experienced this issue?




I have the exact same problem! Cannot open the program - hope it will get fixed soon.



I’m also experienceing this issue. I feel it is because I am unsure what to put in the “Name” field of the registration form. It might be helpful to send the name that the license key is associated with.

I am having the same problem. I was hoping to come here for an answer. Well, I guess it helps that I am not alone.

I am having the same problem as well.

Ditto here.

Same problem here!

Same problem !

do you all know each other?

fwiw, the licensing system is being tested the last few releases… there were others who were experiencing the same (or similar) problem as you all.
i thought the kinks were worked out but apparently not…

it’s the weekend so maybe don’t expect mcneel help until tomorrow at the earliest.

I have received the message from the License Manager. Please let us know, what we have to do when the problem is solved.

see this thread: