Intralattice

In IntraLattice on the Frame menu there is a selection for “Conform Surface to Surface”. If I create 2 surfaces from 3 points, it works fine. If I create a polycurve and then extrude a surface, this fails with the error message “Surface with id: … failed to load”. If I want to create curved surfaces that will load into IntraLattice, how is this done?

It will be better if you put an example. But let me guess with my Crystal ball, a polycurve will certainly generate a polysurface not a surface ? So it must be a Brep in Grasshopper. Try to stay on surface.

latticeCirc.gh (6.3 KB)
simpleCircles.3dm (77.3 KB)
Inside Rhino I cannot figure out how to test if I have a valid Brep object. To keep it simple I created a couple of circles extruded them, and then select the inside faces to connect the lattice. Trying that failed. Do I need to create the Breps inside Grasshopper? Is there a way to test for it being a polysurface vs a surface? Is there something to convert it to, such as a mesh that would work better?
-thanks for your help

Your Brep is valid but you can’t feed Intralattice with it. You need surface, it is why I used Deconstruct Brep but faces are still no surface they are trimmed surface, Intrallatice convert them to untrimmed surface in order to be able to have a grid. Nu and Nv are integer not double. I was also obliged to suppress 0 length curves …
It is not easy, language in Rhino is not always the same as Grasshopper …
So you have many thinks to learn, I don’t know a good tutorial on this. See that




Also Intralattice is now not the better choice for volumization. You better use Dendro plugin.


latticeCirc.gh (36.1 KB)
And a version with another way of doing.
latticeCirc_LD.gh (40.6 KB)

I can see the wiser choice is to import curves & generate the surfaces inside Grasshopper. Thanks for the pdf reference as well.
The Dendro plugin looks great, problem I am having is that when I download it and add it to the directory:
C:\Users\Gary\AppData\Roaming\Grasshopper\Libraries
the IntraLattice plugin no longer shows up on the Grasshopper menu. If I look at File>Special Folders>Components Folder they are both there, but do not seem to load. I did exit/restart Grasshopper ( and restarted rhino) but to no effect. So there is no Dendro or IntraLattice menu.

For Dendro read carefully the Food4Rhino page. It is a matter of obscure “Coff” search also on this forum.
I have the 2 plugins without any problem.

From the pdf, I did disable that setting:

Open Rhino. Type the command:
GrasshopperDeveloperSettings
Make sure “Memory load *.GHA assemblies using COFF byte arrays” is unchecked.
Is still disabled, is that the one you are referring to?

Yes this one.
Also in order to work all gha, dll … must be unblocked.

Tracked down the issue I had with getting Dendro to work. For Windows 10 in the properties, you have to select the zip file then in the ‘General’ section click the ‘Unblock’ before unzipping it.

hi
I want to import a grasshopper file(.gh) into a cad software like catia. but it returns an error.
what do you suggest me to do?

Hi - you will have to bake the geometry that you need into the Rhino document. Then export that geometry from Rhino in a format that Catia supports.

excel seems to be involved but that procedure looks rather bothersome and out of logic to me.

Thank you so much.