Installing shader nodes for Grasshopper / Raytraced (Cycles)

Good idea for future releases, won’t stop GH on Rhino5 from trying to load it.

I’m going to fart that question off to @will since he may have an opinion on what would work best if something like a package manager ever became available :slight_smile:

@MarcusStrube, since this is probably going to happen more and more, the next weekly WIP release (should be Tuesday unless it gets cancelled) will load GHA files from a folder where GH in Rhino5 does not look. This will allow users to install GHAs for Rhino6 only. We still need to do some testing so I won’t tell you where this folder is until we’re certain it’ll work as advertised.

I found it, thank you.

A reminder that latest version can always be found here:

4 posts were split to a new topic: Manage Cycles/Raytraced repeat of texture with GhShaderNodes

Hello. played a bit with grasshopper today. rhino wip example.3dm (2.9 MB)

tried a basic setting with the nodes.
do not understand if this is a bug or feature but it’s funrhino wip (13.4 KB)

rhino wip example.3dm (2.9 MB)

The error you see is related to RH-38781. Baking the geometry (and then assigning your own material again to it) should get rid of the buggy drawing.

1 Like


I was wondering if there is a way to set some basic parameters (like a colour or diffuse texture) for the OpenGL views when using a Cycles XML material? The pink is nice, but not practical :stuck_out_tongue_winking_eye:

Currently there is no way, but it is on my list to write a function that does that.

Until then you could of course set Cycles for Rhino as your current renderer. It should render the Cycles XML materials correctly.

I look forward to that. Then I will finally be able to use the Disney shader for everyday work.

I’m going to try a workaround and see if works ok. The problem right now is I work with OpenGL views all the time, and I can’t look at all pink objects all day! But I’ve made a custom display mode and set it to use Object’s color for shading. Now I can just change the object color to something similar to the Cycles XML material, so while designing it doesn’t look so bad.

Is it broken again? I used the latest release from github and Rhino WIP is up to date. I am getting the TargetInvocationEception and FileNotFoundEXception errors on all of the nodes it looks like

I did make some changes to the internal setup. I’ll check if I need to release a new version when I am at the office.

Edit: got caught up in bug fixing, but this week I can definitely check.

I just posted a new .RHI for the shader nodes. Compiled against current public BETA, you can find it at

1 Like

error on install:

I’m actually not sure if grasshopper components should be installable from a .rhi. Just get the .zip, unpack somewhere, and place the files in the appropriate special folder ( File > Special Folders > Components Folder).

also not working :frowning:

Hmm, not sure what happened here. I was under the impression I installed latest BETA, as that is the track I am on, but for some reason I see I have a newer build. I am assuming a new public BETA will be out sometime tomorrow. If that is the case I’ll rebuild against that (and double-check first I really have latest BETA).

I’m surprised that this works for people because I didn’t see you removing the mark of the Internet from those files before you tried to load them into Rhino/Grasshopper.

When I download files from t’Internet, the files are given a file attribute that marks them as having come from t’Internet and dotnet will NOT load them with that mark (they are cursed and have the mark of the devil upon them).

If I haven’t opened the zip file with the Windows File Explorer yet then I can right click it in Explorer and select properties and check the unblock checkbox. I can then use Windows File Explorer to open the zip and its contents wont be cursed with the mark of the Internet.

Files in a cursed zip, if opened via the file explorer, are themselves marked as being from the Internet.

If you have already unzipped them and copied them to an other folder then either: select each file individually in explorer and uncurse them. Or… delete them all, uncurse the zip then copy them again from the uncursed zip.

@nathanletwory, you warlock! Why are you cursing the files? :smiley: