Input objects not working - Solution Exception error


When I add any of the input objects (i.e. SDGeometryInput, SDTextfileInput) they show the following error:
“1. Solution exception:Method ‘GH_Structure’1.get_FirstItem’ not found.”

This is preventing me from using shapediver! Please let me know if you can help steer me in the right direction.

I am working on Rhino 5 for mac, and have updated to the latest version.


Screen Shot 2020-04-19 at 5.00.29 AM|690x257

Which version of the plugin are you using: 1.5 or 1.6? If you are using 1.5, please update the plugin and try again. We will try to reproduce the issue on our side.

I initially installed 1.5, which gave me the same error. I then deleted it and installed 1.6 - the error persists.


We could not yet reproduce this bug with Rhino 5 for Mac on our side. We will test on more configurations. Can you confirm whether this only happens for the input components (SDGeometryInput, SDTextfileInput, SDImageInput) or if you also get similar exceptions for other components of the ShapeDiver plugin?

I believe it is indeed only affecting the input components. I have not gotten an exception for any other components I’ve tried.

I’ve attached some more screen shots of error messages to hopefully help clarify.

Thanks for your time and work on this!

The errors you are showing typically arise with conflicts between several assembly versions. I suggest to clean all ShapeDiver-related files and reinstall the plugin from the latest 1.6 archive. Just in case, try to download it again from food4rhino, maybe the first download was corrupted.
You can just see the list of files you need to manually remove from your components folder in the newly downloaded archive.

Since your error messages seem related to the Squid components, you can then also try to remove ShapeDiverSquid.gha from the ShapeDiver files and see if you can load the standard ShapeDiver components without problems.


I get the same error message on all ShapeDiver input components, running a similar setup: Rhino 5 for Mac and the ShapeDiver Plugin 1.6

I could eliminate the Loading Errors concerning the Squid components by removing ShapeDiverSquid.gha, but the problem with the input component remains.

I don’t know if this could be related, but I can’t get the settings of the input components to open (should be a double-click) And also I’m missing some of the names of components in the dropdown-menu (see screenshot)