Input File Name disappears on upload

When uploading a file (import geometry in my case), the file name appears briefly and suddenly disappear as soon as the upload is completed.

While uploading:

Once upload completed:

It’s just a minor glitch but it is counter-intuitive and it is causing difficulties to some end-users.
It also helps to see the file name as a reminder of the file I am working on.

It would be great if it could be fixed.

I cannot reproduce the issue on my end. Can you tell me which OS and browser you are using? Ideally, you could point me to a ShapeDiver model that I can test with with a sample file to upload, in case there is a specific problem with this model or file.

Hi @mathieu1

The problem consistently appear across all my models, with any input I tried.

You can try on this model, but also any of the 8 most recent models on my account.

You can use this as an input file (also, you can use it in any of the 8 most recent model on my account).
standardTest.3dm (178.8 KB)

On my end, I tried the following browser / OS and the problem is always present:
chrome, edge, firefox on Windows 10 and brave, chrome and Firefox on Ubuntu 20.04.

Also, on Brave + Ubuntu I have problems uploading .txt files, they just never load.


Our team tested on multiple configurations and still cannot reproduce this. Just to make sure we are talking about the same issue: do you mean that as soon as you click on upload, the file name instantly disappears from the input text field? Or do you mean that when you upload a file in Edit mode and save settings, then the file name does not show the following times you open the model view page?

If you can confirm that we are in the first case scenario, then please share a screen recording showing the whole upload process.


I just noticed this behavior is only happening on embedded models (via iFrame). When accessing the very same model in the platform everything work fine, and the filename stay visible.

I confirm I am not talking about edit mode. Here is a video of the whole process:

I think we managed to get to the bottom of the issue! I could reproduce the problem using an iframe. I have filed a bug and will let you know once we have a fix.

1 Like