Input field


#1

Hi everyone,

I need to restore the input bar on rhinoceros, how can i do this?
The input bar is useful in order to select and choose the options when running also basic commands such as “extrude” “offset” ecc.

Thanks!

Filippo


#2

Rhino preferences > Legacy > Use text field…etc.


#3

the screenshot shows the single window modeling layout is being used and as of the latest beta release, i don’t think there’s a way to use the legacy command line yet.

.

you’ll either have to go back to the original layout by typing TestSingleWindowModeling then open a new window… (in which case, you may have to switch the preferences as described by max)
or
use the mac rhino command popup which you’re seeing now… if you’re unable to enter command options in that dialog then go Preferences->Themes then tick the box ‘always provide input field for typed values’… when that option is selected, the letter for command options will be underlined and you can just type them (followed by return/space) in order to get at the other options.


#4

I agree… and it is always at the same position on screen. No funky windows flying around over the viewport where the modeling/drawing process happens.

Clean and simple like back in the day:

=)

But the new mac interface is getting close to that. That is great! Keep up!


#5

Hi, i’m able to type the commands, but the command line doesn’t show the options, even with the “use text field” option set on on.
Let me show another snapshot: in the “fillet” command (and several others) the command line and the yellow text field doesn’t show the command options…for example “trim” or don’t trim lines…
I can’t remember by heart all the options for all the commands…?


Perhaps it will be a simple solution: a two lines command line which show all the options for all commands and/or the option for restore the previous (windows like) command bar.


#6

hmm… something is wrong in your screenshot… there’s supposed to be an input field while running the commands but i guess yours is lost in space somewhere.

i’d try resetting rhino by deleting the .plist file:

• quit rhino
• go ~(user)/ Library/ Preferences
• find the file com.mcneel.rhinoceros.plist and move it to the trash
• launch rhino.

if you can’t find your user library (which is hidden by default on the last osx versions), click the finder icon in your dock, at the top of the screen click on the GO menu, press&hold the option key, you’ll see an item ‘library’ appear… click that- it’s your user library.

upon restarting rhino, it will be like a fresh install so you’ll have to reconfigure any of your custom settings.


#7

WOW!!!
It’s fixed now!!!
Finally i can restart my work!!!

THANK YOU!!!


#8

no problem… glad you got it working :thumbsup:

have you hooked your laptop to a larger display recently? the only time i experienced a lost dialog box like you have was when i did that… it was quite a while ago though so i’m not sure if it’s still an issue.