Increase brep quality

Hi,

Quick question, is it possible to increase the brep quality in rhino3dm. The majority of the objects looks fine but sometimes they are a bit to course. I looked into the MeshingParameters but afaik its not supported in rhino3dm.
Is the mesh quality of the breps already baked in the rhino file?

It might cause display issues if your objects are unreasonably far from the origin.
Also check your “Render mesh quality” setting here.
image

can you post a file or screenshot of what you are seeing?

unless there is something funky going on nurbs surfaces are generally smooth, but as indicated above their display meshes can be quite coarse.

Yes mesh quality is baked into the objects when saved. As far as I ask know Rhino3dm does not have the ability to change those meshes. Using something like Compute display meshes can be recalculated.

1 Like

Its nothing wrong with the meshes surfaces, its just that the quality between exporting it as a dwg solids and importing this into 3rd party sofware vs importing it as rhino3dm with python is different.

Instead of having like 16 segments on a arc then its maybe 6 segments if that makes sense.

Thanks for the reply, will look into the compute display meshes.

As has been said here, rhino3dm does not have meshing capabilities, so breps must have a render mesh prior to saving the 3dm file. @xy236’s comments about objects far from origin and mesh settings are spot on.

You mention arcs are segmented, How are you importing those, and into which software?

I see.

Concerning the arcs, I meant arcs on a brep object. So if the case is that its already meshed within the 3dm file then its nothing more we can do about it :).

Im using blender and 3dsmax to import rhino3dm. Looks identical in both.

1 Like

Right, you are looking at a mesh representation of the brep.