Inaccessible Rhino Sun Panel

Good day,

I’ve recently been having problems with the Rhino Sun panel not being accessible (the panel that controls location of the Rhino Sun)

In the drop down menu that shows layers, properties, etc the rhino sun option is nowhere to be seen, and accessing the panel through the render tab (sun logo) does not open a panel despite the command lines showing some activity.

Any insight into the matter would be great! Thanks much,

Additionally I am experiencing the same thing with the Environment Editor, as well as “Sun” or “Environment Editor” commands

Hi Jin - is Rhino render the current renderer?


Hi Pascal,

I am currently using V-ray for Rhino 6, but reverting the renderer to Rhino Render did not have much of an effect

Hi Jin - can you try making Rhino current and then restart Rhino? Do you see the panel?


No luck -

Also, there was an episode about 2 weeks ago where the toolbar settings began reverting back to default without my input, so I went through and deleted a .rui file, as per the online recommendations in regards to a similar problem. It fixed the issue then but things like this began happening not long after.

Maybe it’s an issue with that? I’ve tried uninstalling and reinstalling rhino multiple times since then but the problem has persisted.

Hi Jin - please try running Rhino once as an administrator, if you have that access on this machine - close it again then go back and start normally - is that ant different?


Hi Pascal,

Sorry - how would I specify running it as an admin? I am currently running it from the “admin” account on this pc (the only other one is the public one)

Thanks for the help

Hi Jin - Right-click on the Rhino icon and choose ‘Run as administrator’.


Ah, thank you - sadly that didn’t work either :frowning:

This is what the command line looks like when I try the sun options

and then nothing else happens

Hm. It doesn’t show up in the panels docked on the right? Do you have more than one monitor? You might try testResetWindowPositions - does that do anything? I’m not even sure how it affects panels.


Tried the command, restarted Rhino and no dice. I am currently running two monitors on Windows 10

Also, I see a command right when Rhino starts up that reads

“Blocking plug-in Renderer Development Kit UI.”

Does that have anything to do with it?

Yep… see if you can locate the plugin -

C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp
Check it’s Properties (right click) and if it shows the control to Unblock it (On the top level page of its properties, I think, at the bottom) do that and hit ‘Apply’


Hold up got side-tracked with another task - I see options for 'read only" check boxes

Will let you know in due time, thanks for the input

Got it!

Had to check it in the plug-in manager but it’s back up and running.

Thank you very much Pascal - best regards.


Hi Jin - good deal, thanks for letting us know.


Indeed, when a plug-in got load-protected (for whatever reason) the command-line will also print that the plug-in is blocked.