Importing Rhino geometry as new family

Hi, I’m importing rhino geometry to revit space as a new family.
This exact same script that worked before is having this issue. I put the geometry to 0,0,0 as well.
Any hints?

Check the category output as well as the path to the Family Template.

Does this happen if you place a new New Component Family as well? How about in a new revit file?

Can you string all your input to verify they are not nulls. Thanks.

Yes, I’ve checked all my inputs. Even new revit files still don’t do it. I checked it allows me to create a blank family without geometry. But whenever I add the geometry, it shows that exact same error.

please right click on the geometry component and internalize and post a gh file with just that. Thanks.

Hi Japhy, here’s the gh file.
0315 help.gh (37.7 KB)

I exploded the brep and rejoined. (Feet units .01 tolerance)

Nothing i’m seeing was indicating Bad Objects, but I could see how these tapered surfaces could be really close.

hmmmm i guess it’s the geometry looking weird then… i replaced with another geometry then worked. Good its not bug. Thank you!