Importing PBR Materials - Textures are missing after re-boot

I read the following article: PBR Materials (New in 7). It says “You can create a material yourself or download a PBR material from Poly Haven or ambientCG and load it into Rhino directly from the zip file.”

Did it, works great. Closed file, re-booted computer, textures are missing.

Deleted PBR Material, Imported Again. See that the textures are being put into a var/folder/… instead of the Render Content folder. Looks like the var/folder/… is deleted after re-boot.

Moved Zip file (PBR Material) from Downloads folder to a folder I created for my PBR materials and see the same behavior.

var:folder screenshot.pdf (96.0 KB)

I can physically move the texture files from the var/folder to Render Content folder and then re-map the textures to the files in the Render Content folder, but it is time consuming.

I’d like to import PBR materials from Poly Haven and have the textures saved in the Render Content folder, but cannot figure out how to do it. Is there a setting in Rhino I am missing?

Read a few articles that other Mac apps are having similar issues due to permission settings on Mac iOS. Tried all of their suggestions, but it did not help.

Hi Phil - I’ll see if I can reproduce this.
@phil5 - so far I am not seeing this - I created a pbr material from a downloades zip file, applied the material to an object, saved and closed the file & Rhino - reopened, it was as expected, closed and re-booted the machine and all is still as expected on opening the file… So we are doing something differently.
Can you please post the results from the SystemInfo command in Rhino?


Hi Pascal, thanks for the quick reply. It seems if you import and re-boot quickly, the var/folder is still there. I’m not sure how long it takes for iOS to clear the temporary folders out. Maybe check again in the morning.

On your system are the textures saved to a var/folder or the Render Content folder? If I could save the textures to a folder that isn’t private when I import the PBR, I think it would solve the issue. But I don’t see it as an option. But I may have overlooked something.

Here is my System Info:

System Info.txt (5.5 KB)

Also, here is a sample file:

Missing Textures.3dm (5.3 MB)

Hi Phil - yorur file opens here with correcty embedded textures - a folder is created with the embedded textures dumped into it - do you not see that, or am I missing the point of the problem you describe?


Hi Pascal,

When I originally saved the file, I selected Save Textures. However, I do not see a folder where the file is saved. Is the folder in another location? Here is a screenshot of the Finder window where the file is saved:

Folder where file is saved.pdf (72.7 KB)

I also exported the file with Save Textures selected (Missing Textures for Pascal.3dm) and do not see a folder associated with this file either. Also, noticed that the file size is 89kb vs the original model is 5.6 MB. New exported file attached below:

Missing Textures for Pascal.3dm (87.4 KB)

Hi Phil - the texture are embedded in the 3dm file - when the file opens, if the textures are not found on the machine, they are (should be) extracted to a folder and used from there.


Hi Pascal, to verify, I will need the var/folder to be deleted. I will try to re-create the missing file message in the morning by re-booting my machine and opening the file again. Will also check after the weekend. Thanks for your help looking into this.


Hi Pascal - I’m not sure what fixed it, but my system is now working as you described. I see the embedded file folder now and did not receive the missing file error. Thank you very much.

Embedded Filles Folder.pdf (57.2 KB)

Here are the steps I took yesterday if someone else sees a similar issue:

  • Updated from Monterey to Ventura
  • Changed Read/Write Permissions on Rhino’s Content Folder

To update permissions, I followed these steps from a post where someone was experiencing the same issue with another application:

  • From Finder click on Applications and search for [application that is giving you the error]
  • Right-click on it and select Show Package Contents options
  • Right-click on the Contents folder and select Get Info
  • Go to bottom of screen to Sharing & Permissions
  • Unlock the padlock
  • Click on the Settings icon (with three dots)
  • Change all three users to “read & write” to allow app to make changes to sys
  • Lock the padlock
  • Restart the application

Changed Permissions of Rhino Contents Folder.pdf (184.8 KB)

Again, I am not 100% what fixed it, but it is working now.

Really appreciate your help and look forward to working with the PBR materials. They are impressive.


Hi Phil - thanks for the update, I’m glad it is all working!