Importing common model shortcut

rhino

#1

I have been trying to make a command to import a specific common model like inserting a human or in this case a C-plane gizmo to make it more easy to set C-plane to a model. the command opens the model but when I try to use the import or insert command again the command hangs. The command string looks like this;

!-_insert _enter C:\Users\FredJohn\Documents\RhinoAid\Cplanegizmo.3dm
_o _enter _pause _enter _enter

Do anyone know why the import/insert command locks after running this?


(Pascal Golay) #2

Hi scenogrfi - try this:

! _-Insert "Path to file" _Enter _Pause _EnterEnd

You can put a 0 where the Pause is to always insert at the CPlane origin.

-Pascal


#3

Thanks Pascal! But the problem remains! Your stringcommand works as mine BUT when i try to use the insert command to import another object and hits the filebrowsing button in the top of the insert window nothing happens and it is impossible to exit the window. Only thing is to restart Rhino!
I thougt it may have to do with the insert options in the command window, that this command line somehow locks up the insert command in a surtain option? I tried to specifie all the settings with this string;

!_-insert File=Yes Browse C:\Users\FredJohn\Documents\RhinoAid\Cplanegizmo.3dm
Objects _Enter 1 _Pause 1

With my first command string the insert sort of locked to the first inserted object. If I made a second button to insert a second object the first one showed up instead. With this new string I can alter between the two.
But the problems remains when I try to insert a object via the insert window,


(Pascal Golay) #4

Hi scenogrfi -
Make sure there is a space after the "!"
I’ll see if I can reproduce the problem you are seeing.
-Pascal


#5

Thank You Pascal! The problem still appears; The insert command hangs when I try to browse for a new file.after I used my command string
But I discovered something odd. If I replace the ordinary insert command (keyshortcut - aliases) with this macro;

! _Insert Browse

the insert command works as normal!
Now I tried to write direct in command field “! _-insert” ( and I assume the"-" make me run the command in command mode?) and insert a model via command options. If I try to insert (with default insert) a model after this same problem occurs.
It seems like the ordinary insert command gets “infected” by the earlier command mode insert and is waiting for me to give options in the command line while the insert window is open, wich is not possible. Is this a bug?