Imported .3mf file meshes gets weird shading

Any fix for this? Other formats work well but 3mf tends to show like this.
Long time since I used a meshmodeling software but it makes me think of “phong angle” Perhaps the same thing? Or something else entirely, anyhow. It shows like this despite which display mode is used. and RebuildRenderMesh didn’t help


Try the _Weld command

Didn’t work, thanks though :slight_smile:

upload the file when you can.
also try unifymeshnormals
and clear all the materials/display settings for the objects.

Here you go. I exported just a few parts into a new 3mf. It’s still the same if I import the exported file
test.3mf (4.9 KB)

I’ve tried UnifyMeshNormals (forgot about it), tried again just to make sure but still nothing.
Just ran a ClearAllObjectDisplayModes per your suggestion, no difference.

Thx!

_Unweld :slight_smile:

2 Likes

Sweet! That did the trick!
Thanks mate! You were so close with your first guess, just the opposite I guess :stuck_out_tongue:

I’ve never understood what the weld command(s) really does though