Import vectors to Rhino 5 from AI 2020 - stroke styles not visible


I am new to Illustrator. Wanted to prepare some 2D drawings, then edit them in Rhino and finally extrude to 3D. The problem is that when importing to Rhino (ver. 5) I cannot see the curves styles that are applied in Illustrator (strokes, transforms…).

I tried different export options and the closest I got is to export to DWG and then import it in Rhino. However, even then if more than one stroke is applied to a curve, the import fails.

Thank you in advance for your help!


You have to expand appearance of those curves before exporting. Rhino does not support those kind of effects.

Thanks for your answer. I tried to expand all the elements but that doesn’t help.

In this case you better use Outline Stroke

One path

After Outline stroke, every dash is a closed shape

Imported in Rhino. The version I chose was AI version 8

1 Like

Yup! This one actually works! Thanks for that!

And is there any option to make them surfaces instead? Say, these lines drawn in Illustrator have 1 pt width (by the way, is it possible to set millimeters as default units for stroke widths, etc.?) and I would like them to appear in Rhino in the same way - surfaces with defined width rather than no-width curves running through the mid axis.

Thanks in advance!

Yes, go to preferences and in Units tab set the default stroke to mm (it is the way I’ve configured it)

Do you mean you want to give them thickness? If that is what you are looking for, the answer is yes.

Select the curves and go to Surface>ExtrudeCurve>Straight

If you want them to be solid select the option Solid

1 Like

Coming back to the first question - thanks! That is what I was looking for.

Regarding the thickness, I meant something different. But I just realized that the option in Illustrator you have mentioned before is the solution: Object -> Path -> Outline Stroke. After that all the paths from AI are now closed curves in Rhino and I can easily prepare them for 3D printing.

Many thanks! Have a good one!