Import STEP model issues


#1

Hello,
I tried to import the following 3D model into Rhino3D:
https://grabcad.com/library/sololift2-wc-3
And it appears that the result has some issues:


For some reason, there is a large round surface that isn’t trimmed. Besides, the object doesn’t have a bottom surface.
Is it due to some problems in the model? How can it be fixed?


#2

Here is the original STEP file itself:
SL.zip (2.0 MB)


#3

Is this question so hard that nobody can answer it?
Or is it a wrong or poorly worded question?
I would really like to know if it can be fixed easily or I’m supposed to manually recreate the parts that seem to be wrong.


(Pascal Golay) #4

Hi igvk - I see the problem - it is fixed in the V6/WIP. I’ll attach a file from V6 saved as V5, in case that helps.
WC-3_v5.zip (2.9 MB)

thanks,

-Pascal


#5

Oh, I see. Seems like a bug in V5.
Thank you very much!
The bottom is still missing. Is it due to a problem in the original file?


(Chuck Welsh) #6

Hi Igvk,

I think I’m the only one who can figure that out, and I’m out of the office until Monday. I’ll get back to you as soon as I can.


#8

Thank you!
Looking forward to your answer.
One more issue - the colors of the original (e.g. letters on top) are lost. Can it be fixed?


(Chuck Welsh) #9

Hi igvk,

The bottom is not actually missing. It just fails to shade. This is due to a problem in the original STEP file. I’ve attached a 3dm with the input geometry for the bottom surface. It is the untrimmed surface along with the curves that are supposed to trim it. The Top view is zoomed in to the problem curve, which is red.

I recently added code that is supposed to detect this type of problem and try to fix it. Any “healing” code has to be heuristic by nature, and there will always be some example that it won’t detect. I will see if I can adjust the detection algorithm to handle this case.WC-3_Face_11518.3dm (36.9 KB)

In order to see the color on the letters, you will have to import in V6 without joining. Notice the parenthetical remark on the import options dialog next to the “Join Surfaces” check box.


#10

Hello chuck,
So the only possibility so far is to load it in V6 WIP, it won’t work in V5?


(Chuck Welsh) #11

Yes, that is correct. You can have both V5 and V6 running at the same time. If you prefer to work in V5, just use V6 to open the STEP file and save the result as a V5 file.


#12

Hello chuck,
Do the letters show as colored in rendered viewport when you import them in WIP without surface joining?
And how to manually fix the problem with bottom shading due to incorrect geometry?


(Chuck Welsh) #13

Hi igvk,

The colors show up in a shaded view, but not in a rendered view. STEP import assigns object colors to the surfaces, but not materials. Maybe @pascal has a way to transfer the colors to materials. I don’t know anything about rendering.

To fix the geometry problem, isolate the pair of surfaces that use the ugly edge. Call UntrimAll, keeping the trimming curves. Repair the curves by exploding, splitting off the big loop. adjusting what is left to join up, and then re-trimming the surfaces.

My V6 code to automatically fix this problem should have worked, but some low level intersection code was not behaving as expected. When that gets fixed the import should just work for you. Thanks for the report.


(Pascal Golay) #16

Hi igvk - SynchronizeRenderColors will match object material colors to layer colors or object colors - does that do anything you need?

-Pascal


#18

Pascal, SynchronizeRenderColors works.
Thanks, didn’t know that it was needed.