Import STEP file question


#1

Hi,
often I download a free model from GrabCAD in STEP format.

I open the file in Rhino and I see in block manager all the file names for each part.

I guess this is correct but I dont really understand block manager, I DO understand layers.

Is there a way to open a STEP file and have all the parts appear as individual layers?

Many thanks

Rich


(Chuck Welsh) #2

Hi Rich,

STEP files have entities for assemblies (nested blocks) and layers. Many files contain both types, so we have to import the assembly entities as block and the layer entities as layers to keep the intent of the export. I think @pascal may have a script that will convert blocks to layers. He will let you know if he does.

Chuck Welsh
Robert McNeel and Associates


(Pascal Golay) #3

Hi Rich- you can try this script-

ExplodeBlocksToLayers.zip (2.6 KB)

To use the script, extract and save the .rvb file from the attached zip archive, then drag and drop the saved rvb over an open Rhino V4 or v5 window. This will load the script, set it up to load on startup in the future and register the alias

ExlodeBlocksToLayers

that will run the script much like a regular command. An alias can be typed or added to a toolbar button or keyboard shortcut (F-key).

-Pascal


#4

Thank you both for your help. I followed your steps and run command, it seems to create a few layers then stops with an error?


#5

I selected the whole model. I guess I have to select correct parts?


(Pascal Golay) #6

Hmmm- I’ve run into errors before, and managed to fix them so far, - seems each file has a quirk, maybe a naming convention or something - but I need the step file to test with- can you send it to me via http://www.rhino3d.com/upload ?

thanks,

-Pascal


#7

Pascal,
please don’t go to any trouble on my behalf. I was just testing it…It is not a priority…

I downloaded step file from Grabcad :smile:

http://grabcad.com/library/fractal-design-define-r4-pc-case-1/files

Can you get it from here ok?


(Pascal Golay) #8

Hi Rich- I got it, and the script ran fine here- like buttah - it did take a while, but no errors… so, I wonder why it went wrong on your side?? I ran the same script that I zipped and posted, but, just in case I made a mistake, I’ll post it again, unzipped- just replace the file that you unzipped previously- maybe restart Rhino for good measure. And maybe, reopen the step file from scratch. The one I got was called “Fractal Design Define R4 Black.STEP”.

ExplodeBlocksToLayers.rvb (7.5 KB)

-Pascal


Bad imports with STEP, FBX and OBJ
#9

Thanks Pascal. Do I select all items then run command or do I have to select a specific part?


#10

I just run it in Rhino V5 and it worked perfect. Many Thanks