Import OBJ Shapediver

hi! :slight_smile:

I am dealing with some issues regarding the import of objects with the PRO account.

Here is a screenshot of what is happening.

The mesh seems to not be upload properly. I tried with different meshes, closed ones, with different file sizes, but couldn’t find the reason of why the mesh is upload as in the pic. I send you also an screenshot on how I applied the UploadGeometry command from Shapediver.

Thank you!,

Try adding Rebuild Mesh from Pufferfish after the upload component to clean the geometry and let me know if you still have issues with imports.


Hi Pavol!

thank you for your answer.
Just tried and still not working. This is the result again:

The upload OBJ should be a pink bunny. The obj for the bunny its completetly fine. I will attached it as well.

BUNNY2.obj (843.3 KB)

The BUNNY2 mesh contains lot of n-gons and the Geometry Input component supports only quads or triangles. Please follow the steps below to fix the mesh and let me know if you struggle.

  1. Import mesh to Rhino
  2. Run DeleteMeshNgons command
  3. Save as a new OBJ
  4. Upload to ShapeDiver

I uploaded this cleaned mesh and it worked fine.

BUNNY2 no ngons.obj (932.7 KB)


Hi Pavol, thank you so much! it worked :smiley: