I'm having trouble with creases and network surface again

I’m joining a extruded profile to a pipe and it’s tricky but I got the bottom and top to work but the sides always make a crease. In the picture it’s at the (A) side. There are the settings I used. I’ve played around with them all but nothing really helps.

It’s driving me nuts! I’ve tried doing a sweep 2 rail. I’ve tried patch. I’ve even changed the degree of all the curves to 5. I don’t understand why when I use network surface, and it’s set to continuity for that edge, why there is a crease.

3d print full version hollow.3dm (303 KB)

Can anyone take a look at my file and give any suggestions?

I don’t recommend using netwerk surf. In this case start with a tangent surface blend. Create trim curves with curve dup edge. Then use pull back curve (loose) to pull the curves on to the blend. Trim the surface, run surface match (closest points, refine match and preserve isocurve direction).


HI thank you for your reply, but I’m having trouble following along. I’ve attached images as I tried to replicate your work.

Step 1: Tangent Surface blend

Step 2. Duplicate surface edge and pull (loose) to sureface

Step 3: Trim and do match surface

Step 4: Still crease even though I do match surface

Does setting preserve end to tangency help?

1 Like

Use the refine mesh setting option in the e map.

Thanks! It works now!

I guess I’ll write down those settings and make sure it’s like that every time.

I wish I understood blend surface and match surface better. It seems like I need to understand all those different options but I don’t know when I should be using them :frowning:

Hi Stratosfear

I am ashamed to ask again, but I’m having issues with this same pipe again. All I did was change the dimensions around a little and now when I try to project the curves on to the blended surface it doesn’t project properly and when I try loose project it say it misses the surface.

Can you take a look and let me know what I’m doing wrong?

question file.3dm (1.4 MB)

I brute forced a solution but just extruding the curves and trimming the surface but that seems wrong?

Hello - given what you have it looks like you can get away with this -
question file_PG.3dm (201.6 KB)

  • Trim the too-large green surface with the red curve.

  • MatchSrf the blue surface to the green edge for tangency, other end set for tangency as well, and Preserve iso curve direction set and Match by closest points.

Keeping things a little simpler - something along these lines-
question file_PG_Maybe.3dm (1021.2 KB)


Hi Pascal

How did you get such a nice blended surface (green surface) to start with? When I try to make it, it’s all bulgy, which makes any surface I match to it also become bulgy.

I did tangency on both edges and kept the sliders at one.


With these changes I would handle this differently. Create a trim surface. Split the perp surface up with shrink on. Then blend surface Curvature to the trim and position to the perp surfaces. Then split the blend at the perp surface sections. Then match those to Curvature in match surface direction. I did go nuts with all my VSR tricks to get my result class a.

Hello - the green surface was in the file you posted - I just trimmed most of it off and matchsrf-ed the blue surface (also in the file you posted, I just changed the colors in order to describe things more easily) to it.


That’s funny! I’ll take a look this weekend when I have time again. I could have sworn mine looked different…