IGES plugin Error RH6.3?


#1

I have recently started to get this error each time I open RH6, even if I choose to disable plugin.

Think it started around the time I installed the latest RH7 WIP?


(John Brock) #2

Open your file Explorer and browse to:
C:\Program Files\Rhino 6\Plug-ins
Find export_IGES.rhp
Is it the same date as the other plug-in in that folder?


#3

Hi John,

Yes, it appears to be…


(John Brock) #4

Strange…
If it were me, I would use the Programs and Features tool in the Windows Control panel to do a “Repair” on Rhino 6.

Any luck?


(Pascal Golay) #5

Hi David - Try drag and drop of the plug-in from the V6 folder onto Rhino 6 to force loading the right one - does that load? and if you close and re-open Rhino does it still get the right one?

-Pascal


#6

Ran repair John, but still receive error message.


#7

Nope, that didn’t do it either Pascal. Tried saving file and then closing, but still message remains.

Interestingly I can still export IGES!?


(Pascal Golay) #8

Hi David - can you check Options > Plug-ins for the Iges Export plug-in and see (in V6) what the path is? Here it points to the V7/WIP installation, not V6… that ain’t right.

@tim I get no error messages here but my plug-in is pointing at the WIP/V7 and not the V6 plug-in folder…

-Pascal


(John Brock) #9

Right. If the V6 WIP is still installed, it should be uninstalled.


#16

There’s no V6 WIP John


#17

Hi Pascal,

Here’s what I see:


(Pascal Golay) #18

Hi David - yeah, I see - I guess that is the one that works, and for some reason it is also trying to load another… can you poke the Details button on the error message when you next see it and tell me what that shows?

image

thanks,

-Pascal


#19

Not much!

I’ve tried checking the never load again box, but it doesn’t work.

Was just about to install the 6.4 release, unless you think there’s something else I should try first?


(Pascal Golay) #20

Hi David - thanks, I’d go with the 6.4 and see if that sorts it out…

-Pascal


#21

Yes, that fixed it.

First startup displayed this:

Testing C:\Program Files\Rhino WIP\Plug-ins\export_IGES.rhp (and 29 other assemblies) for compatibility…
||/|||/|-|/|/-|–////|/|/-
Compatibility test succeeded in 6.32s

Now there’s no error, and the plugin is loaded.


(Pascal Golay) #22

Hi David - OK- thanks. I still don’t have a good idea what went wrong so I’m not super confident that it won’t happen again when the WIP updates. But lets wait and see, I guess…

-Pascal