I'd like to turn off o-snap alt-toggle behavior

I just discovered the joyful fact that there’s a conflict in alt-usage when drawing a _handlecurve and using osnaps, because if you hold alt to insert a kink you turn osnaps off. That makes it very difficult to do a handle curve based on reference geometry.

Workarounds anyone?

Hi JKolodner - you can use DisableOsnap > Toggle

Hm - OK - but I see the problem you describe… hmmm thinking…

You can type in the specific osnap (say ‘end’) you want and it will override Alt.


and I’m going to do that on every single handle and every point I’m entering?

Up to you… or Shift-Click on the osnaps toolbar - the toolbar changes to one-shot osnaps - that’ll also override Alt if you get at them that way.


I was wondering if you can record a screen capture showing how you’re trying to use Osnaps while also inserting a kink? I was trying to figure it out here to offer some possible workflows but I don’t think I’m getting the intended workflow.

Sorry, I see the issue now…

I’m thinking to draw another curve for the kink and Join after. The result seems the same as using HandleCurve with kinks.

Hi Brian - try drawing a HandleCurve with Alt to force a kink at the placed point while also snapping to a point using osnaps - it does not work… You need to override Alt as far as I can see, with a particular one-shot osnap.


Yep, and this is annoying, not being able to turn off the alt-toggle for o-snap usage. I’d like to just re-assign the hotkey for the toggle to something other than alt. Or assign a different modifier key for kink insertion. Either way.

Hi jKolodner - All that said, I’m curious as to why you use this tool to trace - it seems like the least easily controlable of Rhino’s curve tools…


I wanted to create a smooth sweep curve in 3d that was based on a series of already modeled parts that didn’t have the transitions I wanted. I agree that it was not ideal, I ended up punting on that method and surfacing in a different manner entirely.