I don't think spotlights should do this. Am I wrong?

I have two spotlights within the niche well below the top edge. The light they project should be contained within the walls (surface objects) but when I set the view to [Rendered] the light appears to go through the walls as though they were translucent. Thoughts? Fixes? Note: if I actually render (Rhino render), the lights appear to project correctly and do not go through the walls.

Hello - can you please run SystemInfo in Rhino and post the results here?

-Pascal

Here it is:
Rhino 6 SR13 2019-2-27 (Rhino 6, 6.13.19058.371, Git hash:master @ 17cd8b51accbe17dd04b48028f49d5e77a67f17b)
License type: Commercial, build 2019-02-27
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: RANDY_LAPTOP

Hybrid graphics system.
Primary display: Intel® HD Graphics 630 (Intel) Memory: 1GB, Driver date: 9-26-2017 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 1050 Ti (NVidia) Memory: 4GB, Driver date: 1-11-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 417.71

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-11-2019
Driver Version: 25.21.14.1771
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\RhinoCAM 2019 for R6\RhinoCAM 2019 For Rhino6.0.rhp “RhinoCAM 2019 - The cutting edge CAM plug-in for Rhino 6.0 from MecSoft Corporation”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCAM 2019 for R6\RhinoArt1FileExporter For Rhino6.0.rhp “RhinoArt1FileExporter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp “Named Position”

The lighting (shadowing rather) will fail for cases like this. If you turn on thickness for your wall planes and make them thick enough you will get better shadows.

The left instance has the wall extrusion without thickness, the right instance with thickness on and set to 0.4

Thanks! If I may, what you’ve done is change from a surface (no thickness) to a solid with a thickness of .4. Is that correct? There’s no way to set a “thickness” for a surface, right? (If that’s a stupid question, I humbly accept the label.)

Select your surface, then in object properties panel find the thickness icon, click it. Check the box and set a thickness that gives you the desired outcome

image

Okay - I found the thickness option–never needed to use it before. But check this out: I set the thickness to “1” (inch)

So I tried to “fill” the wall with a solid, but no change:

Hi - according to the developer, this is to be expected as things currently are. Note that you could use the Raytraced display mode to get it right:

You can try to install the Rhino Render Next as well:

run _TestPackageManager and scroll down and install and restart rhino and choose it as the render engine for static renderings.

The Rhino Render also gives OK results, but the OpenGL displaymode is struggeling.

Do note that Rhino Render and Raytraced display mode (or the Rhino Render Next) does give different results since the Cycles engine behind Raytraced is calculating bounced lights and adding this to the objects so they get more exposure:

Thanks to all who responded. I am able to get a static view through Rhino Render where the lights illuminate correctly and do not pass through solids, as I mentioned in the original post. Interestingly for me, when I choose Raytraced–as suggested above–the lights still pass through the walls. Furthermore, Raytraced doesn’t handle lighting very well. Below is a Raytraced image. There are two spotlights directed obliquely at the wine bottles but the rendering doesn’t illuminate them properly nor show reflections from the wine glasses and bottles. That is an error in my opinion. And Raytraced takes longer than Rhino Render to complete an image. I understand that the computer that I use is not comparable to power & graphics capabilities of the ones most on this forum use, but I would think that my limitation would be only in how long the image takes to complete.

Hello - if you can, please post that file or send it to tech@mcneel.com to my (Pascal) attention. You can leave out all but one or two wine bottles to keep the size reasonable.

-Pascal

Pascal, I’ve continued to make changes to the drawing (it’s a current project for a customer). Do you still want it?

@rfm

I’d like the file as a reference for when I try fixing the issue in V7.

Thanks,
-Jeff