I can't install rhino 7 , please help

I have download the install file but when I run it it fails to download the additional stuff. Says “download failed” . I attempted to follow the off line installation instructions however the same thing happen. Any help would be greatly appreciated , cheers, Ian

Hi Ian -

What stuff, exactly?


Hello Pascal,

I don’t know what the stuff is but it appears to be vital. The “rhino_en-us_7.2.21012.11001.exe” downloads however when I run this file displays the message:
“download failed
Rhino setup could not download required packages from internet. To fix problem contact to internet…”

Ah, OK - see if downloading the exe itself, again, sorts it out.


Another work-around worth trying is to stage an off-line installation.

  1. Start the Rhino installer
  2. Click on the settings Gear icon on the initial installer dialog
  3. Select the option to create an off-line installation package

It will take a while to run but when done, you will have a Bootstrapper.exe and a REDIST folder on your Desktop.

Run the Bootstrapper.exe file

Does that result in Rhino being installed?

Sadly not. I located the files in the download folder and moved them to my desktop. Ran the Bootstrapper exe and again “download failed”

Hello, do you know how I should proceed? Cheers, Ian

I just noticed Pascals earlier comment and have downloaded the
“rhino_en-us_7.2.21021.07001.exe” version, This one appears to work,

Thanks for your help, Ian

Same problem with me with the Rhino 7.6 installer. The steps you outlined for an offline installation package do not result in Rhino being installed.

On two different computers, both the default installer and Bootstrapper.exe installs seem to hang on the Microsoft .NET 4.8 Framework download.

I believe the fix to getting Rhino installed is to manually download the .NET 4.8 framework installer and install it prior to installing Rhino.

Work-around to what Microsoft broke:

1 Like

Dear John,

Yesterday I ran into the same issue and was happy to find your instruction.
My workstation is on a secure network, so I have to do the install offline.
I’ve downloaded the .NET 4.8 installer, put it in the redist folder and ran the Rhino install procedure as you described (gear icon etc). This stopped with the same error message.
Unsure what happens in the background so I also I tried installing the .NET 4.8 myself first and then again the Rhino 7.14 installer (also tried the ‘bootstrapper.exe’ which is generated but the same). Nothing works.
Please put clear instructions on the site about this. Thanks, much appreciated,


Problem solved.

I finally borrowed someone else’s laptop to do the sequence. It then appeared that the Redist folder should contain all language files + dotnet installer + VCpp installers. So more then mentioned before.
I then transferred it to the offline workstation. Now it works.