I cannot install pufferfish, I have unblocked

Hi! I downloaded latest puffer fish, unzipped and draged it into the folder “libraries” just according to the video instruction. I right clicked and it already was unblocked. I restarted rhino and the file I am opening says errors that plugin pufferfish does not exist. I restart entire computer and still the same. I also downloaded and installed cockroach via Rhino package manager, restarted the entire coputer and both plugins do not install. They simple do not exist. I did succefully install Ngons via package manager. I have a new computer and just recently purchased rhino so I am using ltest rhino 7 and I tried the latest of all these plugins. Any help?

Hi Björn -

You need to unblock the zip file before unzipping it.

When you open the package manager, do you see Cockroach listed in the Installed tab?

There is no cockroach tab, even though i installed it via the package manager. in the package manager it lists cockroach as installed.

Hi Björn -

I’m not sure what makes you think there should be a cockroach tab.

Ok, well still the file, when I try to open it, say cockroach is missing

I have a feeling that your windows username has non-unicode characters that is blocking rhino from loading library files from C:\Users<username>\AppData\Roaming

Can you create a new user account in windows and avoid any special characters and give it a try.
This happened before to me.