I cannot figure out why my mesh gets messed up when converting from NURBS

Hi everyone! I would say I am sure that there is an easy fix for this but, knowing Rhino (as much as I do love the program), I’m sure the fix is more complicated than I realize. So I have modeled an object using a combination of lofts, sweep2’s and fillets resulting in a closed polysurface. The model looks great until I convert it to a mesh (or stl) and then all of a sudden the model gains a bunch of random polygons, either at the spots where there were isoparametric curves or spots where I filleted. After searching the internet for about an hour, I cannot figure out how to clean this up so help would be appreciated. I will include screenshots and the file. Thank you all and stay safe!


Link to model (google drive): https://drive.google.com/file/d/1Ql54coj9ceDLc3MgM7OHQGrzJERznbqI/view?usp=sharing

Hello - please see

https://wiki.mcneel.com/rhino/meshfaq

-Pascal

Okay of course immediately after posting this I find the solution but I would still appreciate if this were left up and someone had a solution other than this or even if they could explain why this solution works. All I did was copy my model into a new document that had inches as its units. I typically model small objects and work in millimeter documents so a different workaround would be awesome if it did exist.

Hi there. I figured out that copying the object into an inches based document fixed the issue. Do you know why it works in inches documents but not in millimeters?

Thanks

Possibly nothing to do with inches vs millimeters but rather with differences in the DocumentProperties > Document Properties > Mesh between the two files. New documents inherit these settings from the template selected to create the new file.

Hi @pmmanley

Knowing Rhino’s mesher, the main problem in your model is the fact that you have these large surfaces that are not split at the tangents. If you run TestSplitAtTangents, your polysurface gets split at all the tangents it can find, making it easier for the mesher to get the surfaces right, as it deals with each surface within the polysurface as a single piece. Alternatively, you’ll have to get into the detailed mesh settings - look at the FAQ Pascal linked. In the screen dump, the two are meshed with the exact same settings, but lower right is the result of the polysurface after TestSplitAtTangents.


HTH, Jakob

Hi @Normand,

What your saying makes sense, though for some reason I cannot figure out how to run TestSplitAtTangents. Is it a command or do I need to find it in a menu somewhere? If so I have not been able to find it. Thanks for your response.

Best,
Paul

Hi Paul - the command in V6 is DvideAlongCreases with SplitAtTangents=Yes

-Pascal

1 Like