I can`t connect Rhino and Python(Atom)....Please help!

No. Something like that:
I also tried to make a rule for 8080 port but it didn’t work.

Can you try this?

In Atom can you type shift + cmd + P

followed by the view installed packages command

then in the Installed Packages search box type metrics

disable the “metrics” package.

Let me know how that works out.

This is with ESET completely disabled right?

Yep.

Above when you said it worked you meant that the “Save and Run in Rhino” Atom command works right?

Yes, the script worked. Just code completion still not working.

It’s hard to figure this out since I can’t duplicate the problem. Next time I work on this I’ll make the port configurable and that should help. I’ll also keep investigating. If you’re willing to do some tests when I come up with something I’ll contact you offline.
Sorry this is not working for you right now.
Alain

Hi Alain,

we have Cisco VPN installed on all our MACs. Its not possible to reinstall it, because this is setup by our IT Department and they do not reconfigure it. When can we expect to have the port configurable? We plan to work on bigger developments and would appreciate to use it.

thanks, Detlef

Hi Detlef,
I can’t put an exact time on it but it will be very soon because it’s the first thing I’ll do when I get back to this project.
Alain

Hi Everyone
I have the same problem and I can’t connect my rhino to Atom…
I followed up all posts but finally unsuccessful.
could you please help me?
my rhino version is 5.3.2

Hi,
If you followed the advice above can you describe in more details any errors you’re getting?

Does the text Listening for Atom editor requests ... text appear at the bottom left when you run the command StartAtomEditorListener?

If so then what happens when you type this url in your browser?
http://localhost:8080/ping

Alain

Thx Alain for your reply.This is my Error:

and when I use my safari for that address, nothing happen. just “safari can’t open the page”

You may have something in your setup blocking port 8080. If you’re in a corporate environment can you check with your network administrator?

Just a head’s up…Alain added the SetAtomEditorListenerPort to the latest RhinoWIP (5E236w). Give another port a try if you are having trouble with 8080.

For me it is not working at all. Installed Atom with RhinoPython (0.8.4) package, but after creating the mypythonscript.py file, when I’m typing “import” followed by space and “rh” no autocompletion it is triggered in any way.

also when saving using Ctrl+Alt+R, nothing happens in Rhino.

I just created a short script:

import rhinoscriptsyntax as rs
from Rhino.Geometry import Point3d

rs.AddCircle(Point3d.Origin, 5.0)

but no circle it is created in Rhino.

After you run the StartAtomEditorListener command and type the http://localhost:8080/ping url in your browser do you get anything back?

If not and you’re behind a corporate firewall that port may be blocked (even though the client and server are on the same computer) so you may need to check with your network administrator and change to a port that isn’t blocked by running the SetAtomEditorListenerPort command. Something like 65000 maybe? You’ll need to stop and restart the listener (StopAtomEditorListener, and StartAtomEditorListener).

You’ll also need to configure Atom to send it’s requests on the same port (65000?):

  • open the Command Palette (shift+cmd+P)
  • type View Installed Packages
  • find rhino-python
  • click on the Settings button and change the ‘Port Number’ to 65000

Does that help?

Thank you for support. I managed to make this working. After changing the port, I needed to stop and restart the AtomEditorListener.

Here is the output from Rhino console:

Command: StartAtomEditorListener
Listening for Atom editor requests on port 8080 …
Command: SetAtomEditorListenerPort
Success
Command: StartAtomEditorListener
This instance of Rhino is already listening for Atom editor requests. No action taken.
Command: StopAtomEditorListener
Stopped listening for Atom editor requests …
Command: StartAtomEditorListener
Listening for Atom editor requests on port 65000 …

In the browser if I go to: http://localhost:65000/ping

I get: {“msg”:"/Applications/RhinoWIP.app",“source”:“Assembly path”}

Now it is working the autocompletion. I have “<-- Rhino” suggestions and when pressing Ctrl+Alt+R it is creating a circle in Rhino.

Now comes the hardest part. I need to learn Python language and coding in general.

I have a request. It is possible to make the font of the help section from the bottom part of the Atom editor a little more bigger? For me it is a little bit hard to read the text in that part. I need to get closer to the screen which it is not optimal.