I am unable to make a pipe system on my spiral tower

tower.gh (20.6 KB)

Using all the input points for the interpolated curve, it creates some sort of a pinch point on one end of the curve. Looking at the resulting pipe with at least one of them spiking op beyond the surface, the lofted surface seems to have a self intersection. This causes problems with the pipe structure.

A useful result can be achieved by leaving the original curve non-periodic (P inpout set to False).

In the loft options, do not check Align curves as it messes with the seam. Rebuilding the curves helps creating an even spacing in the following surface subdivision.

tower.gh (42.8 KB)

1 Like

Hi Martin,

Thanks so much! Did you youse the multi-pipe plug in? I was wondering how to solve the issue without plug-ins. Thanks!

1 Like

The Multipipe command is part of Rhino 7.

It can be done without but honestly it is so much easier with Multipipe.