Hyphenated import still pops up dialog


Hyphenated Import command still pops-up a dialog about:

This prevents automated processing of files.

1 Like

I doubt we can do anything about that as it is an error message exception.
It’s not part of the expected command flow.

I’ll check with a developer if you can send me a file and the steps to reproduce it.

It’s not my file so I cannot send it. but I suppose the developer knows what’s up with this.

I expect a Hyphenated command to be without dialogs, for else it’s rendered useless for automating.

I think generally that’s true, but exception handling is something different.

If I send you three JPG files that I have renamed to 3DM, and ask you to do some automated process that requires a valid 3dm file, what would you expect Rhino to do?

The issue here is a naming conflict for render content names upon import. Not a critical exception IMO.

If there is a groupname conflict upon import I don’t get a dialog, the groupname is sequentially renamed, so this type of naming conflict issues can be handled.

To answer your question for this case:

I expect the render content naming conflict to be handled like group name conflicts.



Let’s see what the developers say about this:

1 Like

I agree here, dialogs should never interrupt an automated process. These new for V6 warning dialogs pop up with frightening regularity, there has to be an option at least to go back to the V5 style situation where Rhino just did something behind the scenes (if anything) and didn’t bother the user.

I don’t know what it is with the “render content” popup, I get them all the time and virtually none of my files have even have any materials applied, as I don’t do any rendering. I just don’t want to see that stuff at all…


Andy has it open and is working on it.

1 Like

I’m very confused by this new annoyance. When I paste an object between files this thing keeps coming up. I did check the “Do this with any further conflict with this command”, so I expect to never ever ever see this dialog again in the computer I’m using, and in any other computer after I import my saved Rhino Options.

Still, this dialog keeps coming up. I want it gone. ASAP. …In fact I’d appreciate to have a general preference that says “don’t ever ask me or interrupt me about anything rendering related” because that’s is just not how we use Rhino.



This dialog is not going away. Can we please get this fixed ASAP. I want it gone. Can you guys bury this in a setting/preference or something after the first time we are being asked?


As you can see from the public YouTrack bug report, this is “open” on the developer’s list.

Hi John,

What I see open is this hyphenated version stuff, that prevents running scripts. I jumped on this topic because it’s related to my issue, but I’m referring to the manual way of pasting a Rhino object from my clipboard and getting this dialog pop up. Every time. Can we please make sure this also goes away? Thx

Yes, I can get it on the list once I understand it and can repeat it.

Since this sounds like a different but related issue, please start a new topic thread and fully describe it (step by step), so I can duplicate it and get the issue added to the pile.


I’m experimenting same issue with “BlockManager” when I try to set a file property.