How to stop plugins from loading at startup?


#1

Hey guys,
I’ve noticed that ever since I’ve started adding in more plugins on Rhino, it seems to be slowing down. Lag times are starting to get unbearable when navigating views particularly (orbiting, panning, zooming, etc.) - I’m running Windows7 on a Macbook, so its not the most powerful thing, however it was working fine before the plugins were installed. I have a feeling the numerous plugins that are automaticalling loading on start-up every time may be part of the problem (we had the same issue at my office with SketchUp). Is there any way to stop the plugins from loading automatically on startup?
Thanks,
-Ben


(Pascal Golay) #2

Hi Ben- see Options > Plug-ins page- you can disable plug-ins there (for the next time they try to load, i.e. you may need to restart Rhino. But I’d do this somewhat systematically and see if you can figure out which plug-in is causing problems.

-Pascal


#3

Thanks Pascal - I found the Options>Plugins and turned off all of my third-party plugins that were added, but for some reason (even after restarting Rhino) I’m still getting bad lag with oving around the viewport. Whenever I use the ‘right-click-orbit’ the viewport doesnt update in real time with the right mouse button held down (basically I cant see the viewport moving, just the before and after). Is there something I’m missing here?

It is a pretty old MacBook, but it seems odd that this would just start all of a sudden when it was working fine a couple weeks ago…


(John Brock) #4

Do you have a Space Mouse?
If so, disconnect it and restart. See if that’s it.

loading Flamingo NXT slows my loading a lot because it has so much to load up and get going.