How to set lineweight and color of Elment

I created an element by importing two rhino file, One is for model, and another one is for plan (symbol).
I changed everything from attributes panel of element style, but nothing has changed.
Where can I modify color and lineweight.of these imported element?

Hi @archist97,

You need to run the BlockEdit command, select the geometry inside the block and change its attributes to By Parent. This way the geometry inside the block will take the attributes assigned to the block.

Afterwards, you will see the block with the projection color you are choosing (cyan in this case). The line print width and the line print color will be visible when you print the layout, but if you want to see these two attributes while you are modeling, you can run the PrintDisplay command and change its state to on.

I noticed rhino geometry can be recognized as input in grasshopper style definition, if I use VA block definition. I think this method works better in terms of setting and modifying attributes.

One more questions. I tried to create custom beam style with gh style. This is slanted beam. I defined 2D projection and overhead to get correct 2D representation. I can modify color through style editor, but can not modify line type. If I define these 2D as model not as plan, I can do that, but the problems is that both 2D plan and 3D model are shown in viewports. Did I miss something? I attached gh definition.

Custom (19.7 KB)

Hello @archist97,

I could reproduce the issue, it looks like there is a bug in the 2D representation so I am adding it to our list. I’ll keep you updated about it.

Hello @archist97,

This issue will be solved in VisualARQ 2.12. However, take into account what you are trying to do can be done without assigning any 2D blocks as a 2D representation, you just need to use the automatic overhead display option:

I already know tho display option. However, again, the reason I would control the display is to create correct 2D representation.
You can use the option for slatend beam. However, you can not for slanted columns, customized stairs and ramps.
(I would not use VA stairs, because it’s too incorrect not only in 2D representation but also in 3D modeling.)
Another problem with the option is that hidden lines are modified globally.
Please consider these for 2.12.


Hello @archist97,

Ok, I have just added this request to the list.

What are you missing in the current options to set the overhead display? (Apart from setting it by style).

Do you mean stairs created with Grasshopper styles? Something else?

What I mean by “correct 2D representation” is one for GH customized stairs, ramps, slanted columns and walls.
VA does not offer tools to create slanted walls and walls. You need to create these using GH styles.
When it comes to VA stairs, its functionality is too limited to use.

  1. It always end only with tread at the top level
  2. You can not join stairs with slabs.
  3. It does not offer connection detail option with slabs.
  4. You can not use it for steel structure stairs.
    Accordingly, 2D representation can not but be incorrect.

Hi @archist97,

I have just added your requests to our list. Please, feel free to send us any other suggestions you may have.

Just in case, take into account this feature about stairs which could be helpful to you in order to create a better connection between slabs and stairs.

One other request on this point - it would be great and very useful if we could enable overhead display with any Rhino geometry, not just VisualArq elements.

Is this something that might be possible?

Hi @Ben_B,

Yes, it might be possible. We already have it in our list to add this feature in future versions.

1 Like

Hi @archist97, we have just released a new version of VisualARQ (2.12) which fixes this issue you reported (“linetype attribute is not working in plan representations of Gh styles”).

You can check here the news of the new version: VisualARQ 2 - Version 2.12 released


It looks like 2.12 has another bug regarding this issue.

  1. If I place a beam rotated, 2D is represented just as line on plan view.
  2. Rhino has run into crash a few seconds after placing rotated beams.

I used same gh definition.

Hello @archist97,

I see the problem, sorry about that. I’ll reopen the issue to see what happened. I’ll keep you posted.

No problem.
Please let me know when this problem is fixed.

Hello @archist97,

It looks like there is a problem in the Gh definition and depending on which curve you use as a path, it will return a good result or not. In the files attached, you can see that the Gh definition is returning just a line as a 2D represetation, so when you use this Gh file to create the Gh style, VisualARQ is returning what the Gh definition does: a line.

BugBeamsCurve.3dm (2.7 MB)
Custom (16.9 KB)

Thanks. Alfonso.
I’ve revised gh definition.
It looks like 2D representation problem has been fixed.

However, crash problem continues. When I tried to copy, move, and rotate a placed custom VA beam,
Rhino crashes down, especially right after trying to copy.
I attached revised gh definition.

Custom (15.2 KB)


Hi @archist97,

I couldn’t reproduce the crash. Please, make sure you are using the last VisualARQ release. Maybe, could you send us a video reproducing the issue? Do you get any crash report? Could you send it to us?

I always use the latest version of VisualARQ (2.12) and Rhino (7 SR13)
I attached video file, which is gif format


Hi @archist97,

Please, could you send me that file? If you disable the other plug-ins you have installed in Rhino, do you still get the crash?